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Where to Find Help When You Need It

Student Computer Help Web Site
The computer help web site for students provides information about the type of help you can get and
locations where help is available. To find this information, look to: http://rohan.sdsu.edu/~students

Help from the BATS Web Page
BATS (Baseline Access, Training and Support) is a California State University initiative to provide all
students, faculty, and staff with "baseline" access to information resources via networks, training in the uses
of baseline hardware and software systems, and ongoing professional and technical support for utilization
of computer resources at San Diego State University.  You can access the BATS Web Page by pointing
your browser to: http://rohan.sdsu.edu/~bats/

Help in the Love Library Student Computing Lab
The Student Computing Lab's purpose is to facilitate students in completing assigned class work, as well as
provide assistance to students having computer problems relating to the Internet, Netscape, SPSS, File
Transfers, PC Operating Systems, Microsoft Office Software and Business Databases.

Location: 2nd floor of the Love Library building in LL-224
Hours: 10:00am – midnight Sunday
  7:00am – midnight Monday - Thursday
  7:00am  –  6:00pm Friday

10:00 am  –  6:00pm Saturday
            
Help from the Student Computing Help Desk
Phone: 594-3189
Location: Love Library 220
Hours: 8:00am – 4:30pm Monday

8:00am – 4:30pm Tuesday
8:00am – 7:30pm Wednesday
8:00am – 7:30pm Thursday
8:00am – 4:30pm Friday

E-mail: problems@rohan.sdsu.edu
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Introduction

Dreamweaver is a powerful web page creation and web site management tool. It
offers numerous, sophisticated functions that can be used to create professional
quality web sites. Because of this, it’s one of the most popular web authoring
tools among web designers.

This handout is designed to complement content presented in the BATS
Dreamweaver MX 2004 Introductory Workshop. It focuses upon the basic
information needed to setup, create, and manage your own site. The handout is
divided in to several sections, including the Site Creation, Folder and Managing
Your Site, HTML File Naming Conventions, the Dreamweaver Interface, Text
Formatting, and Inserting Images and Creating Links.

Dreamweaver MX 2004 Preferences

One of the major changes in Dreamweaver MX 2004 is the heavy use of
Cascading Style Sheets (CSS) to format page elements and text. Cascading
Styles can be very useful; however, beginning web designers may find these
confusing.

If you prefer not to use CSS, which are turned on by default, follow the procedure
below.

Turn Off CSS Formatting:
Mac

1. Go to Dreamweaver>Preferences and Choose General
2. Uncheck “Use CSS instead of HTML tags”

PC
1. Go to File>Preferences and Choose General
2. Uncheck “Use CSS instead of HTML tags”

Site Creation

To create and manage a web site in Dreamweaver, you must first define it. The
Dreamweaver site creation tools and management tools are extremely useful.
The beginning user might be tempted ignore these tools and go straight to
making a web page. However, after a little use, the power of these tools
becomes apparent. To take advantage of this power, all pages should be created
and accessed through the Dreamweaver Site Files Management Window.

Before you go any further, make sure you have an accessible public_html folder
setup on the server. If you don’t have a public_html folder setup on the server,
complete the section on Creating Your public_html Directory and then
continue with defining your site.
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Defining Your Site:

1. From the menu items located at the top, Choose to Site>Manage Sites

2. In the Manage Sites Window, Click on New and Choose Site

3. Fill in the dialog box: start with Local Info

4. Enter a Site Name: (any thing you wish e.g., My Web Site or Our

Department Web Site)

5. Click the folder icon and Browse to and Select your Local Root Folder:

e.g., public_html

You have defined your local site. Within the same window, now you can specify
the web server to for uploading your files.

7. Select Remote Info (on the left).

8. Set Access to FTP

9. At FTP Host, enter the address of your server e.g., rohan.sdsu.edu

10. At Host Directory, enter the name of your directory on the server e.g.,

public_html

11. At Login, enter your account login or user ID e.g., lsmith

12. At Password, enter your password, *******

13. Do NOT place a check in the box to save your password

14. Click the Test Button (This button tests your Remote Settings. If this test

fails, your web pages cannot be uploaded to a web server and will not be

viewable on the web. Make sure the information is correct in steps 7-13,

and click test again.)

15. Click OK in the site definition dialog box.

16. Click Done in the Manage Sites dialog box.
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Managing Your Site

Dreamweaver Site window is where you create new folders and files, move them
from one directory to another, and upload and download your files.

The Dreamweaver Site Window

Creating New Folders or Files:

1. Select the folder at the top of the Local Files side of the window (In the

illustration above, this is Macintosh HD:Desktop Folder: public_html)

2. Choose Site> Site Files View > New Folder (Mac) or File > New Folder

(Windows)

3. Type the name of the folder and press Return or Enter

Moving Folders and Files:

You can easily move files and folders with in the Site Files Window

1. Click, hold and drag your files and folders to any new location within the

Local Files side of the Site Window.

Dragging and dropping your files between the local and server window is not
recommended. Files can easily be misplaced using this method. Instead use Get
(download) and Put (upload) buttons.

Local Files

The current site

Server files

Connect to server
Download

Upload
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Create or Rebuild the Site Cache:
Why does Dreamweaver ask you to do this? This allows Dreamweaver to keep
an outline of your site in memory and eases site management tasks for
Dreamweaver, such as updating links and search and replace functions.

Uploading to the Server:
With the proper settings, a correctly defined site and a connection to the Internet,
you can upload your files within Dreamweaver. Dreamweaver has its own FTP
function (file transfer function) built right in. There is no need to use a separate
FTP program such as Fetch or WS FTP. To upload follow these steps:

1. With your site window open, click your connect button

This connects Dreamweaver to your web server. When successfully connected,

you should see content in both sides of your site window.

2. Select your local root folder e.g., public_html

3. Click the Put (up arrow) Files button

You will be asked if you would like to Put (upload) the entire site.

4. Click OK

From now on you may wish to only upload individual files. Also, keep in mind that
you can download as easily as you have uploaded. Use the Get (down arrow) to
download your files from the server. This may come in handy if a file on your
local computer gets lost or deleted.

Backing up:
Backing up, now here is an important one. It is highly recommended that you
backup your web site in case of file damage or loss. This is the one activity you
will do without the help of Dreamweaver. To do so, you will need to quit or exit
out of Dreamweaver and then drag a COPY of your site to a safe place, such as
a zip disk or networked drive.
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HTML File Naming Conventions

There are a few things to remember when naming your web page files:

Avoid using upper case Unix servers are case sensitive. It is much
simpler for users accessing your site to
remember and type only lower case.

Don’t use spaces Spaces within names are a no-no.  For
example it’s better to name your file
mary_smith.html as opposed to
mary smith.html.

Use an underscore instead of a space.

Avoid using special characters Avoid the use of special character such as
s
/ & : and periods …..

Keep it simple.

Make sure your HTML files have
the appropriate extension

Your can use either .htm or .html

For example: welcome.html

Keep your filenames short Users don’t like to type in long website
addresses. Keep filenames short, for
example: programs.html

Example site address:
http://www.sdsu.edu/bats/programs.html
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The Dreamweaver Interface

The Dreamweaver interface is made up of several main components. During the
workshop, you will gain experience using these components. The next page
contain an explanation each separate component.

Document Window

Tool Bar

Insert Menu

Properties Inspector Palette

The Dreamweaver Interface

History Palette
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Dreamweaver Components

Toolbar The toolbar offers options for editing your code,
changing your document title, viewing your
page within a browser, and more.

Properties Inspector The Properties Inspector displays object
attributes: Highlight any object you wish to
inspect and the Properties Inspector will
display contextual information about that item
and allow you to make changes.

Insert Menu The Insert Menu allows you to insert a variety
of objects such as pictures, tables, form fields,
special characters, and Flash Movies.

Document Window The document window is the area where you
will be creating your page content.

History Palette The History Palette records every change you
make to your web document and allows you to
“Undo” these changes.

Click and Drag the small handle         up to
Undo your changes.

Click and Drag the small handle         down to
Redo your changes.
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Text Formatting

Dreamweaver offers a number of ways to format text. You can change your text
attributes by highlighting your text and then going to the Properties Inspector.
With your text highlighted, the Properties Inspector allows you to change your
font size, color, and alignment, along with create bold and italicized text.

The Properties Inspector (with text highlighted above)

Font Sizes
HTML utilizes a different font size convention as compared to print font sizes.
Believe it or not, there are only 7 basic font sizes. They range from 1, the
smallest to 7, the largest. The “Hello” text above is at size 7. When you type in a
Dreamweaver document, the default size is 3.

Font Choices
It’s important to realize that when a user accesses your web page from their
machine, the browser uses only the fonts loaded in their machine to represent
text on the page. Because of this, the use of exotic fonts is not recommended.
Users may not have this exotic font loaded on their machine. Other fonts within
their system are used in place of this missing font, and the page may look quite
different than the original.

Play It Safe
Dreamweaver allows you to designate the font you would like display on your
page. It offers a safe method for doing so. Click and hold on the font choice
button. Instead of offering one font, Dreamweaver comes up with a list of fonts.
Why? By using this font list, Dreamweaver makes the user’s machine search for
and utilize one of the listed fonts. For example, if you choose “Arial, Helvetica,
sans-serif” from the font list, when the user accesses your page, the browser
searches for Arial, if Arial is not found, it then searches for Helvetica, and if
Helvetica is not found, it then searches for any other sans-serif font.

Font Font size Font color

Bold & Italics

Bullets & Numbering

Type alignment

Link address
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Inserting Images and Creating Links

Inserting Images:
You can easily insert an image within your site. Conveniently, Dreamweaver

copies an image from any location on your local computer into your web site files:

4. Choose Insert > Image

5. Select the image you would like to insert

Dreamweaver may tell you that this image exists outside of your site files, and

then asks you if you would like to copy it to your site file root directory.

3. Click yes

Creating Links:

1. Highlight the text your interesting in linking

2. Find your Properties Inspector

3. If you would like to link to an outside web site, enter the full address- aka

an absolute URL e.g., http://www.sdsu.edu/ within the Properties

Inspector link box.

4. If you would like to link to a file within your site, click the small folder icon

just next to the link box within the Properties inspector.

5. Browse and choose the file you would like to link to (Most internal links are

relative URLs e.g., myresume.html).

You should now see you text underlined in blue.

Relative and Absolute Links:

URL
URL stands for Uniform Resource Locator. What does this mean? Simply it
means a web site address.

Absolute URL
An absolute URL is a complete URL that describes an exact location of a file on
the web. For example, http://www.sdsu.edu/ (You will need to specify this when
linking to other web sites).

Relative URL
A relative is used to designate the location of files within your site. The use of
relative URLs  makes it easier to make changes and relocate your site if need be.
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Creating Your public_html Directory

Make the Directory & Set Your Permissions on ROHAN

Note:  The information covered in this section only has to be done the first time
you use your account. These settings ensure that your account is set up
properly.

Telnet to ROHAN

• Windows: Choose Start, Run

• Mac: Choose NCSA Telnet

• Windows: At blinking cursor, type telnet rohan.sdsu.edu

• Mac: Choose File, Open Connection

• Windows: At the prompt, type in your login name and your password

• Mac: In the Host/Session Name box, type rohan.sdsu.edu, at the prompt,

type in your login name and your password

Making a “world readable” Directory

• Log into your ROHAN account

• Create a “world readable” directory called public_html by typing the

following bolded text after the rohan% prompt:

• rohan% chmod  711  ~ [press enter]

• rohan% mkdir  public_html [press enter]

• rohan% chmod  711  ~/public_html [press enter]

• rohan% logout [press enter]
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Handout References

Dreamweaver MX 2004 Hands-On Training
Garo Green
Peachpit Press
1249 Eight Street, Berkeley, CA 94710
ISBN: 032120297X


