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Where to Find Help When You Need It

Student Computer Help Web Site
The computer help web site for students provides information about the type of help you can get and
locations where help is available. To find this information, look to: http://rohan.sdsu.edu/~students

Help from the BATS Web Page
BATS (Baseline Access, Training and Support) is a California State University initiative to provide all
students, faculty, and staff with "baseline" access to information resources via networks, training in the uses
of baseline hardware and software systems, and ongoing professional and technical support for utilization
of computer resources at San Diego State University.  You can access the BATS Web Page by pointing
your browser to: http://rohan.sdsu.edu/~bats/

Help in the Love Library Student Computing Lab
The Student Computing Lab's purpose is to facilitate students in completing assigned class work, as well as
provide assistance to students having computer problems relating to the Internet, Netscape, SPSS, File
Transfers, PC Operating Systems, Microsoft Office Software and Business Databases.

Location: 2nd floor of the Love Library building in LL-224
Hours: 10:00am – midnight Sunday
  7:00am – midnight Monday - Thursday
  7:00am  –  6:00pm Friday

10:00 am  –  6:00pm Saturday
            
Help from the Student Computing Help Desk
Phone: 594-3189
Location: Love Library 220
Hours: 8:00am – 4:30pm Monday

8:00am – 4:30pm Tuesday
8:00am – 7:30pm Wednesday
8:00am – 7:30pm Thursday
8:00am – 4:30pm Friday

E-mail: problems@rohan.sdsu.edu
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Dreamweaver Templates and Library Items are powerful web site management

tools. Good web sites have consistent look and feel. Users know that they are

browsing within your web site when they see similar title banners, static

navigational elements, and consistent color schemes. This consistency can be

easy to achieve in a site that is made up of only a few pages, but what if your site

is tens, hundreds, or even thousands of pages? Something as simple as

changing banner graphic at the top or inserting a new link in a navigation bar can

take hours to perform. Using Dreamweaver Templates and Library Items can turn

hours of work into just minutes. They provide “master” pages that are linked to

site pages. A single change to a master page flows to all pages based on this

master page, whether it is two pages or two thousand pages.

Dreamweaver templates also provide tools for web designers who work

collaboratively. Areas of template can be designated as editable or non-editable.

Pages created from a template can have designated regions, which cannot be

changed (Non-Editable Regions). You may ask the question, “Why would

someone want to create a web page with some areas that are not editable?” An

example of this might be a web site maintained by several individuals that have

varying degrees of web design skills. Objects such as tables can be locked down

so that the size of rows or columns cannot be changed on accident (a common

problem). However, cells within this table can be set to allow editing. In other

words, items such as text or images can be placed in these cells, while the

general layout of the table and page are locked.

Introduction
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Templates

Creating a New Template

You can make a template from an existing page or creating a new template from

scratch.

To create a new page:

• Go to FILE>NEW

• Under General, Choose HTML (Basic Page)

• Set up your page using the same procedures you have in the past by

inserting text, images, tables, and formatting as needed.

Once you are satisfied with the design of your web page, you are ready to turn it
into a template.

• Go to the FILE>SAVE AS TEMPLATE

• Name your template in the “Save As Template” box (Don’t add a file

extension such as .html . Dreamwaver will add the appropriate extension).

• Close your new template

A dialog box with the following appears when you close your template, “This
Template Doesn’t Have Any Editable Regions”

• Click OK

Creating Editable Regions

By default, your template is completely locked. Pages generated from this

template have no editable regions and cannot be modified. Because of this, the

next step is to make template regions editable. You will do this via the Templates

Window-a window dedicated to managing templates that is contained in the

Assets Panel. See the procedure below.

• Bring up your Templates window by choosing WINDOW>ASSETS
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If need be, expand this window by click the small black triangle at the upper left-
hand corner.

• Press the Templates button          on the left side of the Assets Window

Within this window, you will see the name of your saved template.

• To edit this template, double click on the page icon in the Templates

window

• Click on or inside any region you want to make editable (For example, you

can make a cell editable by first clicking once inside of it. Or, you can

make an object on the page editable by highlighting it.)

• Now, choose Insert>Template Objects>Editable Region

• When the New Editable Region dialog box appears, name the region

anything you like such as “content area one” (The names of editable

regions can contain spaces and some symbols).

• Click OK

• Continue to create Editable Regions as needed

• When finished Save and Close your template

Figure displays an open
template with 3 separate
Editable Regions
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Creating a Web Page Based on a Template

Now that you have created your template, pages can be created that are based

on this template. Follow the procedure below to create pages that are based

upon a template.

• Go to the FILE menu and choose New

• In the dialog box that appears, Click the Templates Tab, Choose your

template from the template list, and Click Create

The page created from the template has small, highlighted tabs that designate

Editable Regions. Notice that other areas of the page cannot be changed.

• Add content to Editable Regions

• Make sure to SAVE this file to a location inside your local web site folder

Modifying a Template

From time to time you may want to modify a template. What are the reasons for

doing this? For example, you would like to place or alter images or branding

throughout your web site. Or, the actual layout of the sites pages needs to be

altered. Remember, changes to a template effect all pages based upon this

template. Follow the procedure below to modify a template:

• Open the Template window by going to Window>Assets and Click the

Template Button

• Double click the template you

would like to modify

• Make any changes to the template

you like

Remember, within the template itself you

can change anything; however, within pages created from the template, changes

can only be made to editable regions.

Templates Window
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• When finished, choose File>Save

At this point, if there are pages based upon this template, you will be asked, “Do

you want to update all documents in your local site based upon this template?”

• Click Yes

A second dialog box appears that tells you how many changes were made to

pages within your site.

• Click Done

You have now updated all pages based upon this template!

Tip! Always open and modify your templates via the Templates

Window. Don’t alter a template by clicking on it and opening it within the

Dreamweaver site FILES window.

Limitations of Templates

While templates are powerful, they do have some limitations. When you create a

page from a template, content between the opening head tag <head> and head

closing tag </head> can’t be changed (an exception to this is the page title).

Because of this, you can’t place Dreamweaver Behaviors (Javascript) in your

page or use Cascading Styles. When used, both these items make changes by

inserting code into the <head> area of the page. Keep in mind that content in the

<head> area of a document is often unseen and is needed to make things such

as image rollovers or pop-up windows work.

Detaching a Page From a Template

Dreamweaver provides a method you can use if you really need to place content

on the page that alters the <head> or if you would make changes to a non-
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editable region. You can detach a page that is linked to a template. Caution!

When you detach a page from a template, the page is no longer controlled by the

template. Changes within the template no longer affect this page. The following

describes how to detach a page from a template:

• Choose Modify>Templates>Detach from Template

The entire page is now editable!

Library Items

Library Items are similar to templates. Like templates, Library Items can be used

to apply changes to multiple pages. While templates control entire page design,

Library Items are used for individual page elements.

Creating a New Library Item

• Make sure the Library window is open

• Choose Window>Assets and click the Library Items button

• In the Library window, click on the

small Add Library Item icon

You will see a new, untitled Library

Item within the Library Window.

• Click on the word “Untitled” and

rename your Library Item with any

name you like

• Open your library item by double clicking its icon in the Library Item

window

• Create any object you would like, such as a navigation bar, image map, or

graphic

Library Item Window
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• Save your library item

Using Library Items

• Open any page you would like your Library Item to be included in

• Drag the icon of your Library Item from the Library window to this new

page

Editing Your Library Item

Library Items should only be edited via the Library Item window. Follow the

procedure below to edit your Library Items:

• Double clicking any Library Item within the Library Item Window

• Making your changes as needed

• Save Your Work
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Line Breaks <br> and  Paragraph Returns <p>

What’s a Line Break?

Line Breaks can be thought of as single space between one line of text and

another. Sometimes this effect is desirable. For example, a person’s title and job

description (text passage) may be separated by one or more line breaks. A Line

Break looks like this in HTML Code: <br>

Line Break Trouble

Web Designers commonly copy text (using COPY and PASTE commands) from

a word processing document and paste this text into their web pages. This is a

good method for placing content

in a web page. Often, however,

when copying content from a

word processing document,

such as MSWord, and pasting

into your web page, Line Breaks

<br> are inserted in the HTML

code at the end of each line of

text. These “Line Breaks” that

suddenly appear in the HTML

can make formatting your page

challenging (see right).

Often when a browser window is resized, the column of text on the page resizes

and wraps to fit in the resized browser window. This is a desirable effect!

Dreamweaver Code View
with <br> Line Break tags
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On the other hand, where ever a Line Break occurs a new line will start. Text that

has been copied and pasted into a Dreamweaver web page, may have a Line

Break following every line.

When a browser window is

resized, this text still

resizes and wraps to fill the

window. However, the Line

Breaks no longer occur at

the end of each line.

Because of the paragraph

“resizing itself,” Line Breaks

now occur in the middle of

the paragraph and cause

the text to start a new line

in the wrong place (see

example at right).

Working with Line Breaks

Creating
Easily create a Line Break on your page:

• Hold the Shift key and Press Enter (PC) or Return (Mac)

Deleting
You can open a page in the Dreamweaver Code View and delete any undesired
<br> tags. This method is perfectly fine, although the easiest method for
removing Line Breaks is to use the Dreamweaver Design Mode:

• While in design mode, position your cursor where the next line starts (after
the Line Break) and press your Delete key. Repeat as nescessary.

• Preview your page in the browser and resize the window to make sure
that no undesirable Line Breaks still exist.
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What is a Paragraph Return?

Paragraph Returns can be thought of as double space between one line of text

and another. Paragraph Returns often separate one paragraph from another. A

Paragraph Return tag often comes in pairs (one at the beginning of a paragraph

and one at the end) and looks like this in HTML Code: <p>Your text here</p>

Working with Paragraph Returns

Creating

Easily create a Paragraph Return on your page:

• Press Enter (PC) or Return (Mac)

Deleting
You can open a page in the Dreamweaver code view and delete and undesired

<p> and </p> tags. This method is perfectly fine, although the easiest method for

removing Paragraph Returns is to use the Dreamweaver design mode:

• While in design mode, position your cursor where the next line starts (after

the Paragraph Return) and press your Delete key.

Line Breaks vs. Paragraph Returns

These two methods for creating space between lines of text are often confused.

In truth, Paragraph Returns chunk text into separate paragraphs (regardless of

the length of text in the paragraph). Dreamweaver recognizes these as separate

paragraphs, and because of this, paragraph formatting can be applied, such as

centering the paragraph, with out affecting neighboring paragraphs.

Line Breaks just create space between lines. Dreamweaver does not consider

these separate lines individual paragraphs. Paragraph formatting applied to one

line, carries over to every neighboring line that is separated by a Line Break. A

person might try to center (a paragraph formatting attribute) a line separated by

Line Breaks and find that the entire page of text become centered.
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Both Line Breaks and Paragraph Returns do have their specific uses. The best

way to understand how to use these is to experiment!
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Handout References

Macromedia Dreamweaver MX 2004 Hands-On Training
Garo Green
Peachpit Press, 1249 Eight Street, Berkeley, CA 94710
ISBN: 032120297X

Dreamweaver MX 2004 Help System (Using Dreamweaver)
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