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Student Computer Help Web Site 
The computer help web site for students provides information about the type of 
help you can get and locations where help is available. To find this information, 
look to: http://rohan.sdsu.edu/~students 
 

Help from the BATS Web Page  
BATS (Baseline Access, Training and Support) is a California State University 
initiative to provide all students, faculty, and staff with "baseline" access to 
information resources via networks, training in the uses of baseline hardware and 
software systems, and ongoing professional and technical support for utilization 
of computer resources at San Diego State University.  You can access the BATS 
Web Page by pointing your browser to: http://rohan.sdsu.edu/~bats/ 
 

Help in the Love Library Student Computing Lab 
The Student Computing Lab's purpose is to facilitate students in completing 
assigned class work, as well as provide assistance to students having computer 
problems relating to the Internet, Netscape, SPSS, File Transfers, PC Operating 
Systems, Microsoft Office Software and Business Databases. 
Location:  2nd floor of the Love Library building in LL-224 
Hours:  10:00am – midnight Sunday 

   7:00am – midnight Monday - Thursday 
   7:00am  -  6:00pm Friday 

10:00 am -  6:00pm Saturday 
               

Help from the Student Computing Help Desk 
Phone:  594-3189 
Location: Love Library 220 
Hours:  8:00am – 4:30pm  Monday 
  8:00am – 4:30pm  Tuesday 

8:00am – 7:30pm  Wednesday 
8:00am – 7:30pm  Thursday 
8:00am – 4:30pm  Friday  

E-mail: problems@rohan.sdsu.edu 
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Creating A Web Page  
The Word Wide Web (WWW) is rapidly becoming the medium for exchanging information 
around the world.  Whether you want to make a Web Page for your syllabus, or your own “home 
page” – this workshop is for you.  Using Netscape’s Page Composer you will create a basic Web 
Page without learning HTML.  Then you will learn how to transfer your Web Page to SDSU’s 
ROHAN web server and make the Web Page available for anyone to look at on the WWW. 

The following topics will be covered… 
 

Student Computer Help Web Site ............................................................................................... 1 
Help from the BATS Web Page.................................................................................................. 1 
Help in the Love Library Student Computing Lab ..................................................................... 1 
Help from the Student Computing Help Desk ............................................................................ 1 

Creating A Web Page...................................................................................................................... 2 
What is the Internet? ................................................................................................................... 3 
What’s the difference between the Internet and the World......................................................... 3 
Wide Web?.................................................................................................................................. 3 
What can I do on the Internet? .................................................................................................... 3 
What is a URL?........................................................................................................................... 3 
What is a home page?.................................................................................................................. 3 

Considerations Before Creating Your First Web Page ................................................................... 4 
Principles of Good Web Page Design ......................................................................................... 4 
Who will see your Web Page? ....................................................................................................5 

Creating Your Web Page................................................................................................................. 5 
HTML Editors ............................................................................................................................. 5 
Using Netscape Composer .......................................................................................................... 5 
Help using Netscape Composer .................................................................................................. 5 
Saving Your Page Correctly........................................................................................................ 5 

Creating Web Pages ........................................................................................................................ 6 
Starting From a New Page .............................................................................................................. 6 
Checking the Spelling ..................................................................................................................... 6 
Saving and Browsing Your New Page............................................................................................ 6 

Formatting Your Web Page......................................................................................................... 6 
Changing Text Color, Style, and Font............................................................................................. 6 
Inserting Horizontal Lines............................................................................................................... 7 

Adding Tables to Your Web Page............................................................................................... 7 
Inserting a Table.............................................................................................................................. 7 
Adding and Deleting Rows, Columns, and Cells............................................................................ 7 
Changing a Table ............................................................................................................................ 7 
Using the Table Properties Dialog Box........................................................................................... 8 
Moving, Copying, and Deleting Tables .......................................................................................... 9 

Adding Pictures (Images) to Your Web Page ............................................................................. 9 
Inserting an Image........................................................................................................................... 9 
About the Images Properties Dialog Box...................................................................................... 10 

Setting Page Properties.............................................................................................................. 11 
Setting Page Location, Title, and Author...................................................................................... 11 
Setting Page Colors and Backgrounds .......................................................................................... 11 
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Linking and Publishing Your Page ........................................................................................... 12 
Linking Within the Same Page...................................................................................................... 12 
Linking to Other Pages.................................................................................................................. 12 
About the Link Properties Dialog Box.......................................................................................... 12 
Linking to Images.......................................................................................................................... 13 
Make the Directory & Set Your Permissions on ROHAN............................................................ 13 

Telnet to ROHAN ..................................................................................................................... 13 
Making a “world readable” Directory....................................................................................... 13 

Transfer Your Web Page to Your ROHAN Account - Windows................................................. 14 
Viewing your Web Page on the Web............................................................................................ 14 
Making Changes to your Web Page.............................................................................................. 14 
 
 

What is the Internet? 
The Internet is a worldwide network of computers- actually, a network of networks- that allows 
the exchange of information to and from virtually anywhere on the globe. 
 

What’s the difference between the Internet and the World  
Wide Web? 
The Internet has been around since 1969, when a basic text version of it was created as a project 
of the Department of Defense. The World Wide Web -a system of interconnected information 
that is a part of the internet- began in 1989 and introduced a multimedia (text, graphics, and 
sound) format. 
 

What can I do on the Internet? 
People use the Internet for commerce, for research, or for fun. You can buy or sell almost 
anything, retrieve information, send and receive email anywhere, join a newsgroup, “chat” with 
others electronically or just play games. 
 

What is a URL? 
A URL (uniform resource locator) is another type of electronic address-for Web pages. It’s the 
code that identifies where a particular site can be found. Most begin with http://www (in fact, 
http: is often treated as a given and left out of published addresses) and end with an extension 
indicating whether it’s a business (.com), school (.edu), government (.gov), or non profit (.org) 
site. 
 

What is a home page? 
A home page is the first or main page of a Web site. All the other pages of a site are generally 
accessible through links from the home page. 
 
FTP: File Transfer Protocol. An alternative (to the World Wide Web) way of transferring files 
over the Internet. 
WS_FTP:  A software program for Windows used to transfer files over the internet. 
Fetch: A software program for Macs used to transfer files over the internet. 
HTML:  HyperText Markup Language. A collection of style information (font, font size, layout, 
etc.) used to define components of a web documents. 



 4  

HTTP:   HyperText Transfer (or Transport) Protocol. The standard computer protocol for 
identifying accessible Web Pages. 

Considerations Before Creating Your First Web Page 
One of the most exciting opportunities created by the explosion of the Internet is the possibility 
for anyone to become a publisher by making a Web Page.  The following are tips for good 
design. 
 
Principles of Good Web Page Design 
Below are several tips for novice designers which allow for creativity, but still take into account 
good design principles.*  
 

Well Designed Web Pages Poorly Designed Web Pages 
• are well organized and easy to 

use  
• serve the needs of some 

audience and are designed with 
that audience in mind  

• contain valuable content and are 
attractive  

• use white space to enhance the 
readability and appearance of 
the page  

• are up-to-date:  information is 
current and all the links work  

• use graphics to compliment the 
text  

• make sparing use of flashy 
items (such as blinking text, 
animated icons, movies, sound 
files, etc.)  

• have text that is readable (size 
& color factor in here)  

• are consistent in their design (if 
multiple pages are used) 

• lack a logical organization 
• leave the user wondering what 

the purpose was 
• try to put ALL of the 

information on a single page or 
bury all the information under 
numerous menus 

• have misleading or inadequate 
titles/headings/links  

• contain old information  
• are unattractive 
• use colors which render them 

illegible  
• contain links that have expired  
• overuse all the available bells 

and whistles  
• have typos  
• break copyright or plagiarize 

the materials of others 

 
The following are real examples. 
Good Web Page Design 
• http://www.adamsgallery.com/ - simple design, easy to get around, nice use of color. 
• http://facs.scripps.edu/surf/surfing.shtml - good use of image and analogous colors on 

home page. 
• http://comnet.org/wildswan/ - nice use of color, logical organization. 
• http://new.realtor.com/sandiego/nbregion.asp - able to customize searches, useful links. 
 

                                                 
* Adapted from: http://www.hope.edu/resources/lib/www/goodbad.html 
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Poor Web Page Design 
• http://home.earthlink.net/~cjrogan/ - too much info and graphics, slow load time, poor 

color choices. 
• http://www.artcenter.edu/ - confusing, don't know where to go next. 
• http://www.stanford.edu/~jennig/ - no formatting, no organization. 
• http://www.stanford.edu/~sganesan/ - incorrectly named homepage Index.html, instead of 

index.html causes viewer to see files not homepage. 
 

Who will see your Web Page? 
Remember that your Web Page will be viewable by anyone who has access to a web browser 
(Netscape, Explorer, etc.).  This means that it is important to be aware of the content of your 
page, both words and graphics.  The following website provides information on what is 
appropriate as a faculty, staff or student of SDSU:  http://www-rohan.sdsu.edu/hpguide.html 
 
Creating Your Web Page 
HTML Editors 
Web Pages are built in Hypertext Markup Language (HTML).  HTML is the programming code 
that creates the you actually see.  While learning HTML should be a goal of everyone who works 
extensively with Web Pages, the invention of HTML editors  has made creating HTML without 
knowing HTML, very easy.  One of the HTML editors that is easy to use is Netscape 
Composer.   
 

Using Netscape Composer 
1. Open Netscape Communicator. 
2. Click on the Communicator menu, and select Page Composer. 
3. Create your Web Page, just as you would any other word processing document. 

Help using Netscape Composer 
1. From within Composer, Select Help 
2. Select, Help Contents 
3. Select, Composing and Editing Web Pages 
 

Saving Your Page Correctly 
1. Click on the File menu, and select Save As 
2. Windows: In the Save In  window, choose the Desktop as the location you want to save the 

Web Page. 
Mac: Choose Desktop as the location you want to save the Web Page 

3. Windows: In the File name window, type: index.html 
Mac: In the Save as: box, type index.html 

4. Choose Save 
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Creating Web Pages 
 
Starting From a New Page 
To start a new web page, use one of the methods described below. Once you've started a page, 
you can add and edit text just as you would in a word processor. 

To start from a blank page: 

Open the File  menu and choose New; then choose Blank . A Composer window containing a 
blank page opens.   

To start from a page already created in Composer: 

1. Choose Page Composer from the Communicator menu.  
2. Open the File menu and choose Open Page. 

− Type the path and name of the file you want to use, or click Choose File to search for the 
file. 

3. Click Composer.  
4. Click Open. A Composer window opens containing the specified file.  
 
Checking the Spelling  
1. Select a word or part of a document, or don't select anything to check the entire document.  
2. Click Check Spelling.  
Use the Check Spelling dialog box to correct misspellings and to edit or add words to the current 
dictionary. Click Stop when you are done. 
 
Saving and Browsing Your New Page  

To save a page: 

− Open the File menu and choose Save.  

To view your page in a Navigator (browser) window: 

− Open the File menu and choose Browse Page. The Composer window remains open behind 
the new Navigator window.  

 
Formatting Your Web Page 
 
Changing Text Color, Style, and Font 
1. Highlight the text you want to format.  
2. Open the Format menu and choose Character Properties; then click the Character tab. All the 

options are explained below.  

Font Face 

Click to select the font you want. To have your page use fonts specified by a reader, select 
Variable Width or Fixed Width. 
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Font Size 

Click to select the size of the specified font. 
In the list of font sizes, you'll see a menu of point sizes (8, 9, 10, 12, 14 and so forth), the relative 
HTML font scale (-2 to +4), or both. You can specify which type of menu you want in the 
General panel of the Composer Preferences dialog box (Windows only).  

Color 

Click Use Color, then click the color button to choose the color of the selected characters. The 
color button is the rectangle to the right of the Use Color button. If the current text color is black, 
then the color button is black. 
Click Don't Change if the selected text contains more than one color. 
Note: You can specify default text color in the Colors and Background panel of the Page Colors 
and Properties dialog box.  

Other Colors 

Click the color button in the Color section to display a colors dialog box. Then click Other. 
You'll see a dialog box where you can choose a custom color. 
 
Inserting Horizontal Lines 
1. Click the location in the Composer window where you want the line to appear.  
2. Open the Insert menu and choose Horizontal Line.  
3. To specify the line's height, width, alignment, and shading, double-click on the line.   

 
Adding Tables to Your Web Page 
 
Inserting a Table 
1. Place the insertion point where you want the table to appear in your document.  
2. Choose Table from the Insert menu.  
3. Use the New Table Properties dialog box to set up your table.  
4. Click OK.  
 
Adding and Deleting Rows, Columns, and Cells 
To add to your table: 
1. Click where you want to add space.  
2. Open the Insert menu and choose Table; then choose Row, Column, or Cell.  
 
To delete: 
1. Click in a row, column, or cell.  
2. Open the Edit menu and choose Delete Table; then choose Row, Column, or Cell.  
 
Changing a Table  
You can change a table's caption or border, or the width, height, alignment, color, or background 
of a table or parts of a table. 
1. To change an entire table, click anywhere inside it; to change a specific row or cell click 

inside the row or cell.  
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2. Open the Format menu and choose Table Properties. 
3. Click the Table, Row, or Cell tab.  
4. Use the Table Properties dialog box to make your changes.  
5. Click OK.  
The settings you choose in the Table Properties dialog box always override the settings you 
chose when you first created the table. 
 
Using the Table Properties Dialog Box 
Use the New Table Properties dialog box and the Table Properties dialog box to set or change a 
table's characteristics. All the fields are explained below. 
To create new tables, use the New Table Properties dialog box: 
− Open the Insert menu and choose Table.  
To change an existing table, use the Table Properties dialog box: 
1. Click anywhere inside a table, row, or cell.  
2. Open the Format menu and choose Table Properties; then click the Table, Row, or Cell tab.  

Number of rows/Number of columns 

Enter the number of rows and columns you want. This option is available only when you are 
creating a new table. You can also add rows and columns to an existing table. 

Table Alignment 

Aligns the table within the document. 

Horizontal Alignment and Vertical Alignment 

Aligns the text within each row or cell. Default leaves the alignment as it was when the table was 
created. 

Include caption 

Inserts space for a caption, either above or below the table. 

Border line width 

Enter a number for the size, in pixels, of the border lines around cells (table items). Enter 0 for 
no border. Note: Composer displays a zero (0) border as dotted outlines; no borders appear when 
the page is viewed through a browser. 

Cell spacing 

Enter a number for the space, in pixels, between cells. 

Cell padding 

Enter a number for the padding, in pixels, within each cell. This sets the margins of each cell. 

Table width 

Enter a number for the width of the table. Choose "% of window" or "pixels." If you specify 
width as a percentage, the table width changes whenever the window width changes. 

Table min. height 

Enter a number for the minimum height of the table. This is the smallest height the table can 
have. If you add text to the table, the table is resized to fit. Choose "% of window" or "pixels." If 
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you specify height as a percentage, the table height changes whenever the window height 
changes. 
Note: If you are inserting a table within a table, the minimum width and height of the nested 
table can be percentages of the parent cell. 

Equal column widths 

Makes all cells the same width. Deselect this if you want to size each cell individually. 

Cell width 

Enter a number for the width of the cell. Choose "% of table" or "pixels." If you specify width as 
a percentage, the cell width changes whenever the table width changes. 

Cell min. height 

Enter a number for the minimum height of the cell. This is the smallest height the cell can have. 
If you add text to the cell, it is resized to fit. Choose "% of table" or "pixels." If you specify 
height as a percentage, the cell height changes whenever the table height changes. 
Note: If you are modifying a table that's within a cell, the minimum width and height of the 
nested table can be percentages of the parent cell. 

Cell spans 

Type numbers in the rows box and columns box to specify whether you want the selected cell to 
span more than one column or row.  

Header style 

Centers the text in the cell and sets its style to bold. 

Nonbreaking 

Keeps the text from wrapping to the next line. Text will wrap to the next line only if you insert a 
paragraph break. 

Use Color 

Lets you choose a background color for the table, row, or cell. Click Other, at the bottom of the 
color palette, to define a custom color. 
Use Image 
Lets you use an image as the table, row, or cell background. Type the location and filename of 
the image you want to use. Click Choose Image to find an image on your hard disk or network. 
 
Moving, Copying, and Deleting Tables 
1. Click in the table, then open the Edit menu and choose Select Table.  
2. To copy or move: Use the Edit menu's cut, copy, and paste options.  
3. To delete: Choose Delete Table from the Edit menu.  

Adding Pictures (Images) to Your Web Page 
 
Inserting an Image 
You can insert GIF and JPEG images into your web page. 
1. Click where you want the image to appear in your document.  
2. Open the Insert menu and choose Image.  
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3. Specify the image file and adjust settings in the Images Properties dialog box. The dialog 
box's options are explained below.  

Tips: To quickly resize an image, select it and drag the handles that appear at each corner.  

About the Images Properties Dialog Box 
Use this dialog box to insert a new image or modify an existing image's options, such as text 
wrapping, height and width, and spacing. 

Image location 

Type the name or location of the image file you want to insert or modify. Click Choose File to 
search for an image file on your hard disk or network. 

Use as background  

Click to use the image as a background for your entire page. 

Text alignment and wrapping around images ("xyz" buttons) 

Click a button to indicate how you want text postioned next to the image. 
To see alignment changes you've made, view your page in a browser window. The Composer 
window does not show what the browser user will see. 

Dimensions 

Specify the height and width, in pixels, of the image. 

Constrain 

Click to maintain the size settings of the image if you move it within your document. 

Original Size 

Click to undo any changes you've made to dimensions. 

Space around image 

Specify the amount of space on the right and left, and at the top and bottom of the image. You 
can also put a solid black border around the image and specify its width in pixels. Specify 0 for 
no border. 

Alt. Text/LowRes  

Click the Alt. Text/LowRes button to display the Alternate Image Properties dialog box, where 
you specify whether to display text or a low-resolution image in place of the original image. 
It is a good practice to specify alternative text for readers who use text-only web browsers or 
who have graphics turned off. Otherwise, your readers might see placeholder images. You can 
also specify alternative text, or a low-resolution image, to quickly appear while the reader is 
waiting for your high-resolution image to load. 
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Setting Page Properties 
 
Setting Page Location, Title, and Author 
The information you specify in the Page Properties dialog box helps readers locate your 
document on the Web. 
To set page properties, open the Format menu and choose Page Colors and Properties. You'll see 
the Page Properties dialog box. Click the General tab. The options are explained below.  

Location 

Shows the location of the current document on your computer's disk. You cannot change this 
field. 

Title 

Type the text you want to appear in the window title when someone views the page through a 
browser. This is how most web search tools locate web pages, so choose a title that conveys what 
your page is about. 

Author 

Type the name of the person who created the document. This information is helpful to readers 
who find your document by using a web search tool. 

Description 

Briefly describe the document's contents. 

Other Attributes 

The keywords you type here help searching services lead users to your document on the Web. 
Type the category name (obtained from a catalog server) you think best applies to your 
document. Classification names are another method used by searching services to locate 
documents. 
To preview your settings, click Apply; then click Close to accept the changes. To accept the 
changes without previewing, click OK. 
 
Setting Page Colors and Backgrounds 
The Colors and Background part of the Page Properties dialog box lets you set a background 
color or image for your page, and choose colors for links. 
To set colors and backgrounds, open the Format menu and choose Page Colors and Properties. In 
the Page Properties dialog box, click the Colors and Background tab. The options are explained 
below.  

Use viewer's browser colors 

The viewer's color preferences (specified in the General preferences panel) will be used. 

Use custom colors 

Lets you specify color for text, links, and background. Click the button to display the color 
palette and select the color you want. 
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Color Schemes 

Lets you select a scheme from the list. 

Use image 

Click to use an image as the page background. Type the name of an image file. If you're not sure 
of the filename or file location, click Choose File to find the image file on your hard disk or 
network. 
Background images are tiled and override background color. 

 
Linking and Publishing Your Page 
 
Linking Within the Same Page 
To link within the same page, create a target, then create a link that points to the target. 
1. Put the cursor at the beginning of a line where you want to create a target, or select some text 

at the beginning of a line.  
2. Open the Insert menu and choose Target.  
3. Type a name for the target in the edit box (up to 30 characters). If you selected some text in 

step 1, this box already contains a name.  
4. Click OK. A Target icon (visible only in the Composer window) appears in your document to 

mark the target's location.  
Note: Targets are also called anchors. 

5. Put the cursor on the text or image that you want to link to the target.  
6. Open the Insert menu and choose Link.  
7. Open the File menu and choose Browse Page; then click the link you just created.  
 
Linking to Other Pages 
You can link to local pages on your own computer or on your workplace's network, or to remote 
pages somewhere on the Internet. 
You can also create a link using the Link Properties dialog box: 
1. Select the text or image you want to link to another page.  
2. Open the Insert menu and choose Link.  
3. Use the Link Properties dialog box to set up the link. The dialog box is explained below.  
 
About the Link Properties Dialog Box 
Use this dialog box to insert a new link or modify an existing link. 

Link source 

Enter the text you want link to another page or target. If you've already highlighted an image or 
text, you see it here. 

Link to page location or local file 

Type the local path and filename or remote URL of the page you want to link to. If you're not 
sure of the path and filename or a local file, click Browse to find it on your hard disk or network. 
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Show targets in 

Click Current File to see the named targets in the page you're currently editing. Click Selected 
File to see named targets in the file you specified under "Link to page location or file," above. 

Select a named target (optional) 

The targets you see listed here depend on what you chose under "Show targets in," above. 
Targets (also known as anchors) are specific locations in a page. (You can create targets.) 
If you want to link to a target, select one from the list. 

Remove Link 

Click to unlink the selected linked text. If the current selection contains more than one link, an 
alert box appears asking you whether to remove all links. 
 
Linking to Images 
You can make images behave as links in your pages. When the user clicks a linked image, the 
browser window displays the page that the image is linked to. 
1. Click to highlight an image on your page.  
2. Open the Insert menu and choose Link.  
3. Use the Link Properties dialog box to set up the link.  
Tip:  Dragging a linked image from the Navigator window into a Composer window copies both 
the image and the link. 
 
Make the Directory & Set Your Permissions on ROHAN 
 
Telnet to ROHAN 
1. Windows: Choose Start, Run 

Mac: Choose NCSA Telnet 
2. Windows: At blinking cursor, type telnet rohan.sdsu.edu 

Mac: Choose File, Open Connection 
3. Windows: At the prompt, type in your login name and your password 

Mac: In the Host/Session Name box, type rohan.sdsu.edu, at the prompt, type in your login 
name and your password 
  

Making a “world readable” Directory 
1. Log into your ROHAN account 
2. Create a “world readable” directory called public_html by typing the following bolded text 

after the rohan% prompt: 
3. rohan% chmod  711  ~ [press enter] 
4. rohan% mkdir  public_html [press enter] 
5. rohan% chmod  711  ~/public_html [press enter] 
6. rohan% logout [press enter] 
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Transfer Your Web Page to Your ROHAN Account - Windows 
1. Open the WS_FTP program 
2. Click on the New button 
3. Enter host name: rohan.sdsu.edu 
4. Enter user ID: your rohan user name and your password 
5. Click OK  
 
 
 
 
 
 
 
 
 
 
1. On the right hand side, double click on the public_html  folder to open this directory 
2. On the left-hand side, find the location of your index.html page and any images from your 

page. You can use the green arrows to move up a directory. 
3. Select the files on the left hand side you want to copy and press the right-facing arrow 

between the two windows to transfer the files from your computer into your ROHAN 
account.  

4. Click on the Exit  button to close this program. 
 
 
Viewing your Web Page on the Web 
To view the Web Page you have created, open a web browser, and type the following address in 
to URL location finder box: http://www-rohan.sdsu.edu/~yourid 
(note: “yourid” should be replaced by your ROHAN user id.) 
 
Making Changes to your Web Page 
1. Make any changes to your page within composer, using the index.html file stored on your 

hard drive. Save these changes by selecting File, Save. 
2. Follow the steps on Transfer Your Web Page to Your ROHAN Account again. 
3. Note: Each time you make a change to your page on your local hard drive, you must copy the 

page to the server again for the changed page to be viewable. 

Enter: rohan.sdsu.edu 

Click OK  

Enter your rohan user name 
and password 

Click New 
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