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Whereto Find Help When You Need It

Help from your Division/College’s Computer Consultant

Some divisions and colleges have computer consultants assigned to them. You can contact these
consultants when you need help. To determine if you have a consultant assigned to your division or
college, look to: http://rohan.sdsu.edu/~facstaff

Help from the BATS Web Page

BATS (Baseline Access, Training and Support) is a California State University initiative to provide all
students, faculty, and staff with "baseline™ access to information resources via networks, training in the uses
of baseline hardware and software systems, and ongoing professional and technical support for utilization
of computer resources at San Diego State University. You can access the BATS Web Page by pointing
your browser to: http://rohan.sdsu.edu/~bats/

Help in the San Diego State University, Faculty Room
The Faculty Room is staffed Monday through Friday with computing consultants who will try to answer
your questions.

Location: Adams Humanities, 1109
Phone Number: x45727
Semester Hours: 7:30am - 6:00pm Monday -Thursday

7:30am — 4:30pm Friday
Semester Intersession:  7:30am — 4:30pm Monday — Friday

Help from the Faculty Computing Help Line

Phone Number: x41348
E-mail: helpline@mail.sdsu.edu
Semester Hours: 7:30am — 6:00pm Monday — Thursday

7:30am — 4:30pm Friday
Semester Intersession:  7:30am — 4:30pm Monday - Friday

Help from the Staff Computing Help Line

Phone Number: x40824
E-mail: staffhelp@sdsu.edu
Semester Hours: 7:30am — 6:00pm Monday — Thursday

7:30am — 4:30pm Friday
Semester Intersession:  7:30am — 4:30pm Monday — Friday



[N oTo [ odTaTo Il == o 1

[ (XA (o I o (=Y A = = 1
Yot 1 F= 1 o] [V A=Y ea o T €T =T o] a1 o3 1
Flash VEISUS SNOCKWAVE ......covueiii ittt ettt e e e et e e et e e e ea e e e e et s e e s esaeeesetaeeaeennrees 2
[ STT Y o 2
AT o Yo [ 0T ) T 2
The Danger Of SEOMENTING ... ..cuueiiiet e e e ettt e e et e e e s ea e e eeat e s esaaa s eesssaesesabtseeensnnseeees 3
(€410 [S=TaTe STz o] o1 ]c [T 3
NS (Yo I T (o 1N YT PP T UUTPPPRP 5
Freehand TranSTOrMaliONS. .......ccveuee e et e et e e e e et e e e e et e e s e e e e s et essesaa e s saaan e ererasans 7
Changing the Gradient POSition iN OBJECES......ccoiiiiiiiiiee e 8
TaaToTo)atlaTo N ad aTol (oTe =Y o] 1 1Y /SN 9
[aaToTo)a([aTo VA=t (o G AN g 1T o) o N 10
2 TS S - Y= SR 11
ANIMALING WD FLASI oottt et e e et e e ettt e e et et e s e eesa s e e esaeseesetaneeesesanaees 12
ST o 12
oL 11 1= PR 13

S =T o LI YTy 1T Lo [T 14
ShAPE HINES ...ttt e e ettt e e e e e e bt be e e e e e e e e aanbeeeeaaeeeaanbbaeeaaaeeaaanne 15

[\ o] 1T o T ITYST=Y o T T [T 15

1Y o] 1T I 10T [ 16
Frame-By-Frame ANIMaliON.........cuuiiiieeiiiiie et e et e e e e e e st e e s et e e e s esan e s saaan e ererans 16
Using Symbols, INStances, and SOUNGAS ........ccuvuuiiiiiiiiiiieiiiiee e e e e e et e e e e s s e es b e e e e e s s eesaabaanss 17
[T oY 0] 1 1 17
[T aT0 3 oY 1Y 0101 0T S 17

I aTS T =T a1 Y 1 ] o 17
The MOVIE CHP SYMBOL ..cvuiiiiei ettt ettt e et e et e ettt e e e e ta e e e e eaaeresetaaeseeennrees 18
FLA VEISUS LS WV oottt et et e et e et e s e e e et e e et e s eb e e et e esanssebneastnees 18

= 00 1N 19

ST 0101 0T T 20
(OIS (] 0 0TI o1 r= T T T 21
[T [0 AN 1T0] 4 IS To] 16 ] £ 21
T A AN (N AN w1 1o N 21
ASSIONING A Fram@ ACHION .. .ceveeieeiet et e e e e e e e et e e s e et e e s e sbesseaba s eessaaneesees 21

ASSIONING & BUION ACHON: .. ciiiiieeteee ettt e e e e e e et e e e e e s e e e e e ab s e e e eesssssbaba e eeesssensrens 22




Introducing Flash

Flash is a program by Macromedia for creating interactive, animated online content. Animated
simply means "to have movement" -- Flash content does not have to be a cartoon. It is commonly
used to mimic software interface elements such as scroll bars, drop-down menus, buttons, and
navigational systems. The term "Flash" has also come to mean the actual files created using
Macromedia's program of the same name.

Not only is Flash content animated, it is interactive, allowing the user to experience unique results
based on input. This generates creative gaming content such as the "Who Wants to be a
Millionaire" online game at ABC.com.

How to get Flash

If you don't have a copy of the Macromedia Flash software, you can download a 30-day trial
version from http://www.flash.com.

Scalable Vector Graphics

Yet another benefit to Flash content is that much of it is rendered as Scalable Vector Graphics
(SVG). It is much more efficient to download SVG-format file than a GIF or JPEG image. Vectors
are mathematical curves that describe the edges of shapes. Imaging programs like Adobe
Photoshop render artwork with pixels --also known as rasters -- which are fairly memory-
intensive. The advantage of vectors is shown in Figure 1-1.
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Figure 1-1: The smaller Saturns are displayed at 100%. The enlarged raster-based .jpg is blurry, and takes more memory to render. The
vector-based .swf file can display at any size without requiring more memory or degrading in quality.

The SVG implementation is only now being standardized by the World Wide Web Consortium.
The Flash format is the de facto standard, due to Macromedia's early trailblazing, but Adobe has
introduced LiveMotion, which saves files in the preliminary SVG format adopted by the W3C, as
well as in the Flash format. (Assuming the non-proprietary SVG format is adopted by future Web
browsers, Macromedia will no doubt add that capability to Flash.)



Flash versus Shockwave
Flash is Macromedia's program for creating animated movies specifically for online presentation.

Shockwave is a format for saving Macromedia Director files for online presentation (Director is a
more robust program for creating movies; it has a higher degree of interactivity, plus video --
something Flash can't include. It is the standard for authoring CD-ROM presentations).

Both Director and Flash save movies in the Shockwave/Flash (.swf) format for online playback.
Users must have the browser plug-in present in order to view this format. Unlike Director -- which
is quite complex and utilizes Lingo, a proprietary programming language -- Flash was built
specifically for online authoring, and despite many interface similarities, is much simpler. It does
utilize ActionScripts, a basic set of program commands that is much easier to learn than Lingo or
JavaScript.

Lesson 1

The Toolbox

The basic drawing tools in Flash are the Line, Oval, Rectangle, Pencil,
Brush, and Eraser tools. When a tool is selected, the lower half of the
Toolbox displays modifiers unique to that tool. In your copy of Flash,
move your cursor over the image of the toolbox to view the various
modifiers. In the case of the Oval and Rectangle tools, the modifiers are
the stroke color, stroke weight, stroke style, and fill color. It's best to get in
the habit of setting these modifiers before using the tool, as editing color
takes a few more steps.

To draw a flying saucer like the one below, select the Oval tool and
change the default red fill to a medium gray. Click on the Fill modifier and
drag into the color palette that pops up (Figure 1-3).

Flying saucer

Figure 1-2:The Flash Toolbox.



This palette contains the 216 Web colors (colors that won't
dither in Mac OS or Windows). Once you have set the stroke
and fill, draw an oval on the page.

The Danger of Segmenting

Anything you draw in Flash automatically segments itself.
That means the oval you drew is actually two objects: the
gray fill and the black stroke. If you tried to pick up the shape
and move it, you probably moved one or the other
(fortunately, Flash has unlimited undos). To select the entire
shape, either marquee it with the Lasso or Arrow tool, or
double-click the fill with the Arrow tool. Flash indicates a filled
object is selected by displaying a checkerboard pattern on it.
A selected stroke displays a crosshatch pattern (Figure 1-4).
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Figure 1-3:The color palette. . .
g P Figure 1-4: Select the fill, stroke, or both.

Deselect by clicking on the Stage (background). Use the line tool to horizontally bisect the ellipse
you drew. You now have seven shapes on the Stage (Figure 1-5).
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Figure 1-5: Automatic segmenting (exploded for clarity).

To prevent this segmenting, you can group objects as soon as you draw them, but sometimes
segmenting works to your advantage -- as it will in the next two examples.

Undo the line (choose Undo from the Edit menu, or press Command-Z (Mac) or Control-Z
(Windows) and any repositioning you may have done (select Edit > Undo as many times as it
takes to get back to your original gray ellipse) will be undone.

To add corners to the ends of the ellipse, be sure that it is not selected and position the Arrow
cursor close to one end (do not click). A small curve will appear next to the cursor, indicating that
if you drag, you will reshape the curve. Hold the Option key (Mac) or Alt key (Windows) and drag
the end of the ellipse to add a corner.

Grids and Snapping

By default, the Snap to Grid feature is active, which causes the cursor to move abruptly and at
irregular intervals. This is rarely convenient; disable it by unchecking Snap to Grid from the View
menu. The View menu is also where you can make the grid visible or invisible. To set the color
and spacing of the gridlines, choose Modify > Movie.



Add a corner to the other end of the ellipse by pressing Option (Mac) or Alt (Windows) and
dragging the opposite side.

To draw the canopy of the saucer, select the Oval tool and set the Fill modifier to a pale blue.
Draw a circle on the page away from the body of the saucer (hold down the Shift key to draw a
perfect circle). If you had let the canopy overlap the saucer, it would have punched out the
underlying part of the saucer. (If this happened, just select Undo from the Edit menu.)

To punch out the bottom of the canopy, rather than the top of the saucer, double-click the fill of
the saucer (which selects it and its stroke) and position it to cover the lower half of the canopy.
Deselect it by clicking on the white Stage.

The bottom of the canopy can be changed to a concave curve by moving the Arrow next to it
(until you see a curve icon next to the cursor) and dragging downward. Notice how the fills of both
the canopy and saucer body adjust to this change. Select the entire canopy by clicking the blue
fill and Shift-clicking the strokes above and below the canopy. Group them by choosing Modify >
Group.

Details can be added to the saucer with the brush tool. To shade it like the example above, select
the Brush tool and set the Fill modifier to a dark gray color. Set the brush mode to Paint Inside
(Figure 1-6).
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Figure 1-6: Brush modes and an example of each.

Start with the brush entirely inside the fill of the saucer and paint in the shading along the bottom.
You can let the brush go past the edge of the shape because the Paint Inside modifier prevents
the color from going outside the lines. Change the color to white and the size of the brush to a
small tip. Then paint the highlight on the upper right side of the saucer.

To prevent further segmenting, group the entire flying saucer by selecting Group in the Modify
menu. Grouped objects display a box around them when selected.

You can use segmenting to help you draw a crescent moon:
With the Oval tool, draw a yellow circle on the Stage, away from the saucer. To draw a
filled shape with no stroke, set the Stroke modifier to None (the topmost square in the
color palette -- it looks white).
Draw a different-colored circle overlapping the yellow one.

Use the Arrow tool to select the second circle, and press Delete.

Select the entire moon shape, and group it to prevent other objects from segmenting it
further.



Grouping objects prevents them from being segmented by other objects, but also prevents them
from being edited. To change any color in your saucer, you have to "get inside" the group. Do this
by double-clicking the saucer. Notice that the moon now looks very pale. Also notice the Group
icon at the top-left corner of the document window (Figure 1-7).

eV you see this icon, it means you are
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Figure 1-7: The icon for Group editing mode.

Nested Groups

The canopy group is nested inside the flying saucer group (much as you can nest a folder inside
another folder on your computer's hard drive). To paint the highlight on the canopy, double-click
the saucer, to get inside the saucer group, and then double-click the canopy, to get inside the
canopy group. The upper-left corner of the document window displays this nested arrangement
(Figure 1-8).

R get out of groups a level at a time, double-
22y Soene 1| (a4, Group | a4, Group | | o4, Group click the Stage to exit the canopy group, then
—————— double-click again to exit the flying saucer
=« 5 Ot 5 18 group. To get out of all groups at once, click on

the words "Scene 1" in the upper-left corner.

L] i Think of groups in Flash as protective plastic

| sleeves on CDs. You can double-group or

triple-group objects (just like you can double-
or triple-sleeve valuable CDs for greater
protection):

Figure 1-8: The Nested Group icon.

Be sure that you are in Scene 1 rather than your saucer, canopy, or moon group (click
the words "Scene 1" at the upper-left corner of the document window).

Select the moon (it was grouped previously, so it displays a selection rectangle around

it).
Choose Modify > Group.
Choose Modify > Group again.

The moon is now triple-grouped. To change its color, you would have to double-click it
three times before you could edit it. (There is no functional reason for triple-grouping a
single object; but knowing it's possible may help you diagnose problems in the future, as
beginners tend to multiple-group things without realizing it.)

Save your file. You will use your saucer illustration in Lesson 2.



The Object and Transform Inspectors (Macromedia calls palettes inspectors ) allow you to size

and position elements on the Stage. Both can be found on the Inspectors submenu of the
Window menu.
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Figure 1-9: The Object and Transform inspectors.

To precisely position an object on the page, use the Object Inspector to enter the X and Y
coordinates in pixels. You can also precisely size an object. Select the moon you drew and enter
50 for the X coordinate, 60 for the Y coordinate, and 72 for both the width (W) and height (H) on
the Object Inspector (you can use the Tab key to move from field to field in the Inspectors).

To rotate the moon, select it, and open the Transform Inspector (Window > Inspector >
Transform). Enter a rotation of -20° (negative numbers rotate objects counterclockwise).



Freehand Transformations

When you don't need precision, you can scale and rotate using the modifiers of the Arrow tool.
Select the flying saucer, then click on the Scale modifier in the Toolbox (Figure 1-10).

Drag a corner handle to scale
proportionally, or a side handle to scale
one dimension. To reflect an object, drag
a side handle all the way across the
object.

You can also scale and rotate using the
Modify > Transform submenu.

Duplicating and Aligning
Objects

If you wanted a whole fleet of small flying
saucers, shrink the original and Option
(Alt)-drag it to create a copy. Do this
once more for a total of three saucers.

To align them horizontally, select all
three saucers and choose Modify > Align.

Figure 1-10: The Rotate modifier (circled in blue) and Scale modifier (in red).

Align

The button icons in the Vertical

Dertical _ section of the Align dialog box

Align: 00|28 | ol allow you to align objects on their

upper edges, on their centers, or

: on their lower edges. Similarly, the
Space evenly: Edl= =11 Horizontal section gives choices
to align objects on their left edges,
on their centers, or on their right
edges. When aligning objects that
Align: XSS are the same size (like your
saucers), it is unimportant which
button you press in the Vertical

Horizontal

Space evenly: |fplooloo|od section -- as long as it is not X,
which prevents vertical movement.
Match size: X [+ If you want your saucers to be

Align to pags evenly spaced horizontally, in

addition to being vertically aligned,
press any button in the Horizontal

Space Evenly row, and then press
Figure 1-11: The Align dialog box. OK.

There are a few default gradients at the bottom of the color palette. You can create your own
gradients by selecting the Color window button at the very top of the palette, or by choosing
Window > Colors and selecting the Gradient tab at the top of that palette.
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Figure 1-12: The Gradient tab in the Color window.

To create a gradient, select the type of gradient you want (Linear or Radial). Click on a color
pointer at either end of the gradient definition bar, then pick from the Solid colors pop-up menu
(just above the Change button) or the color space (the colored field above the Colors pop-up
menu). Or you can type the RGB or hexadecimal value of the color you want. You can insert up
to 14 additional color pointers by clicking between color pointers on the gradient definition bar.
(For radial gradients, the color at the left end of the bar represents the center of the gradient.)

Changing the Gradient Position in Objects

Let's say you are going to create a night sky with the glow of the sunset on the horizon such as
the one below:

Select the Rectangle tool.
In the Fill modifier, select the Color window button at the top of the color palette.
Click the Gradient tab of the Color window.

Make sure that the gradient type is set to Linear and select the left color pointer on the
gradient definition bar.

From the Solid color pop-up menu (just above the Change button), select a bright orange.

Leave the rightmost color pointer set to black and click in the color bar between the
orange and black color pointers to add a third pointer.

Move the middle color pointer closer to the orange end of the bar.
Select a dark blue from the pop-up list of colors.

Press the New button to add this custom gradient to the list of gradients above. (It will
now appear with the others at the bottom of the color palette for this document).



Close the Color window.

Draw a rectangle large enough to cover the entire Stage (notice that the rectangle
automatically is placed behind the grouped objects -- groups always appear in front of
ungrouped objects).

To orient the gradient so the orange end is at the bottom of the rectangle, select the
Paintbucket tool and click the Transform Fill modifier (the lower-right button on the
toolbox).

Click the rectangle.

Drag the circle at the upper-right corner of the rectangle counterclockwise 90° (you'll
have to guess -- Flash offers no way to create exact Fill transformations).

Since your rectangle is wider than it is tall, you lose the orange glow by rotating the fill 90°. Drag
the square that is now centered above the Stage downward to the top edge of the Stage to
compress the gradient to fit within the rectangle. (You could also move the center point of the
gradient to reposition the entire fill.)

While Flash has many precision features, major limitations include:
The absence of Bézier handles for complete control over curves
The inability to wrap text to a path
The inability to miter corners or square off ends of strokes
The inability to precisely control gradients or do shading other than linear or radial fills

The absence of advanced typographic controls

These limitations means you will find yourself returning to conventional drawing programs when
you need to create really complex or precise artwork, such as a logo or diagram.
To get artwork or photos into Flash, choose File > Import and locate the desired image.

Importing Photography

Photographic images take more memory to render because they are raster-based. For that
reason, you should make every effort to limit their use in Flash projects. You can convert photos
into vector format (losing quality and realism to some extent) by selecting an imported photo, and
choosing Modify > Trace Bitmap. The settings you use to trace will depend on the photo and the
quality of the final output you desire. Color Threshold is the most significant option: the image
quality improves as the threshold is set lower, but the number of vectors -- and therefore the file
size -- increases (see Figure 1-13).



Original Color Threshold=10

Color Threshold=25 Color Threshold=50

Figure 1-13: Color Threshold variations with the Trace Bitmap command; quality improves as the Threshold decreases.

Importing Vector Artwork

Vector artwork can be imported from native Freehand or Illustrator files. (lllustrator 8 files are
problematic and should be saved as version 5, 6, or 7 files before importing.) The grouping and
layering structure in the native application file is preserved in Flash.

Imported photos and vector artwork might need to be "broken apart," a process that eliminates
any group structure and acts on photos like Trace Bitmap (without the control options). Select
Modify > Break Apart to edit your imported artwork in Flash.

Layers are integral to maintaining control over the elements in a Flash movie. Layers appear to
the left of the Timeline at the top of the document window (Figure 1-14).

Objects drawn on higher layers will overlap
objects on lower layers. Layers can be
dragged up or down in the Timeline,

Active Layer (Il I

Guide layer = Layer s * * *1 changing the stacking order of their
Motion Guide | (¢ buide:Layerd = + =+ | contents. Layers can be hidden, locked, or
Normal Layer | [ Layer 4 *+ + « 1 viewed in Outline mode (showing only the
Mask Layer Layer 3 « & | outlines of the layer's contents) by clicking
Masked Layer | @ isysrz 3 s« | thedotunder the corresponding icon.

|__p|Lager1 MR LR

Mew|Motion Guide  Delete Layer

Add New Layer —n-[4] %

Figure 1-14: The Layers section of the Timeline.
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To Add Stars to Your lllustration:

1.

Add a new layer to your file by clicking the white icon at the bottom left of the Layers
section of the Timeline.

Rename the new layer Stars by double-clicking the layer name.

Use the Brush tool to draw some blue stars on the Stars layer (make some overlap the
moon and flying saucer). If you drag the Stars layer under Layer 1, you won't see the
stars at all, because they will be behind everything on Layer 1 -- including the sky-colored
gradient. To move an object from one layer to another, select the object (the sky, in this
case), and choose Edit>Cut. Create a new layer named Sky. Choose Edit>Paste in Place
(this puts the sky-colored gradient in exactly the same position, but on the selected
layer). Move the Sky layer to the bottom-most position.

Drag the Stars layer between Layer 1 and the Sky layer (notice that the formerly
overlapping stars are now behind the moon and saucer).

To hide the Stars layer, click the dot adjacent to it, under the eyeball icon. Show it again
by clicking in the same spot.

View the Stars layer in Outline mode by clicking under the square icon, adjacent to the
Stars layer.

Lock the Stars layer by clicking under the padlock adjacent to the Stars layer.

To delete the Stars layer, click it once to select it, and then click the trashcan below the
lowest layer. (You don't have to delete the stars if you like them!)

Mask Layers

Masks are layers containing filled shapes that set the visible area of underlying layer(s). To draw
the planet Jupiter, you could use a mask to show a circular portion of some multicolored stripes:

Figure 1-15: Using a mask to draw Jupiter.

Add a new layer called Stripes by clicking the New Layer icon below the lowest layer.
Use the Brush tool to draw stripes like those in Figure 1-15.
Add a new layer called Jupiter Mask.

On the Jupiter Mask layer, draw a circle that does not extend beyond the stripes (the
color is unimportant).

Select the Jupiter Mask layer by clicking once on the icon next to its name, then CTRL-
click on the Jupiter Mask layer icon; choose Mask from the pop-up menu.

Mask layers ignore any stroke painted on them. Also, mask layers AND the layers they mask
must be locked for the underlying layer(s) to display the results of the mask. To do any editing of
the mask shape or the artwork that is being masked, you must unlock the appropriate layer(s).
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To Add a Great Red Spot to Jupiter:
1. Unlock the Stripes layer by clicking the adjacent padlock icon.

2. Select the Brush tool and set the Color modifier to red.
3. Paint an oval on one of the colored stripes.

4. Re-lock the Stripes layer to re-establish the mask effect.

The most important reason for using layers is that it is required for animating, which will be
covered in the next lesson.

Animating with Flash

Lesson 2

Flash movies play at 12 frames per second (fps) by default. This is the rate at which most
modems can download the movie fast enough not to cause delays in streaming. You may set
your movie to play faster (more fps) or slower (fewer fps), but you cannot have different parts of a
movie play at different rates.

If, for instance, if you want to animate a seedling growing into an oak tree in the space of 30
seconds, you would make the animation span 360 frames (12 fps x 30 sec). To make the same
animation last five minutes, you would stretch it out over 3,600 frames (12 fps x 300 sec). Both
the frame rate and the duration are controlled with the Timeline.

2 Scene 1 @:@
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Figure 2-1: The Timeline.

The Timeline consists of a row of frames for each layer of the file. Above the frames are the
frame numbers -- notice that only every fifth frame is numbered as well as shaded for clarity. At
the bottom of the timeline is the movie's frame rate (circled in Figure 2-1). You may change this
by double-clicking it.

A given frame may have any number of layers -- it all depends upon the construction of the file. In
this course, specific frames will be referred to by both the frame number and the layer (e.g.,
"frame 10 of the Saucer layer"), much like the game Battleship, in which a specific location is
referred to by both the row letter and column number.

12



Frame 10 Frame 10, Layar X

Figure 2-2: A frame (left) and a layer within that frame (right).

Keyframes

A keyframe is a frame where something on the stage changes, appears, or disappears.
Keyframes are indicated in the Timeline with a white or a black circle. White circles indicate a
blank keyframe (one with nothing on the Stage at that particular frame), and black circles indicate
a keyframe with content.

To create a happy face that suddenly frowns, you would need at least two keyframes: one that
contains the face smiling and one that contains the same face frowning.

1.

2.

In a new Flash file, rename Layer 1 "Face" by double-clicking the layer name.

Add a new layer named "Features" by clicking the New Layer button (the button below
the layers with the "+" on it).

Drag the features layer above the Face layer so the features you draw on it will appear in
front of the face shape.

Click on Frame 1 of the Face layer. (It will turn black to indicate it is selected.)

Use the Oval tool to draw a yellow circle in the middle of the stage. (Notice after you have
drawn the circle, there is a solid black circle in Frame 1 of the Face layer, indicating
something is in that frame.)

Select Frame 1 of the Features layer and draw two black ovals for eyes. Use the Pencil
tool to draw a smile on top of the yellow circle. (The Pencil tool has two modes, Smooth
and Straighten; you'll want to have the Smooth modifier selected to draw the smile.)
Notice that both layers now have a black circle in Frame 1.

Select Frame 10 of the Face layer. Choose Insert > Frame. This adds nine more frames,
but only Frame 1 is a keyframe, as that's where the yellow circle first appears. No other
frame on this layer will be a keyframe, as the yellow circle will never change in the
animation.

Select Frame 10 of the Features layer. Choose Insert > Keyframe. This also adds nine
frames to the layer, but it duplicates the contents of the previous keyframe into Frame 10,
whereas simply adding the regular frame in the previous step did not.

With Keyframe 10 of the Features layer selected (it should appear black in the Timeline),
deselect the face (click on a white part of the Stage).

10. Use the Arrow tool to bend the smile into a frown.

11. Press Return or Enter to preview the animation. For the first nine frames the face is

smiling. It abruptly frowns in the last frame because that is the one in which you made the
change.

13



12. To make the smile last longer, click Frame 5 of either layer, Shift-click Frame 5 of the
other layer, and choose Insert > Frame.

13. Use the Insert Frame keyboard shortcut (F5) to add nine more frames to each layer. (The
keyboard shortcut is the easiest method to add regular frames to an animation and will be
used throughout this course.)

14. Press Return to preview the results (the face takes twice as long to frown, but frowns just
as suddenly).

Frames 2-19 of the above animation may look empty in the Timeline, but they are not. A gray
frame contains whatever was in the preceding keyframe. The truly empty frames are those
beyond Frame 20, which still appear to have thin gray divider lines, and the gray frames marking
every fifth frame.)

In olden days (10 to 15 years ago), animation studios like Disney and Warner Brothers had
legions of artists draw each and every frame of a feature cartoon. The experienced artists would
draw the keyframes (e.g., a picture of Bambi stepping onto a frozen pond, one of him struggling
to stay upright, and a third one of Bambi sprawled on the ice). The apprentice artists would be
given these keyframes and instructions to draw X number of in-between frames (motion pictures
being 30 fps, these "in-between" artists had their week planned). The term tweening comes from
this process and refers to the generation of the in-between states of two images. If you give Flash
starting and ending keyframes, Flash can do the tweening for you.

Shape Tweening

Shape tweening (also referred to as morphing) is when one shape changes into another. You will
use shape tweening to gradually change your smiley face from the previous exercise into a frown:

1. On the Features layer, double-click any frame between 1 and 20.

2. In the Frame Properties dialog box (Figure 2-3), pick the Tweening tab at the top.

Label TSuund THctiunsTTuleening]

Tweening: |_Motion >

(] Tween scaling

Rotate: |_Automatic > |“ |

[] 0rient to path direction
Easing: E[E} D
In Out

[1Synchronize symbols

[1Snap to guide

Figure 2-3: Tweening options in the Frame Properties dialog box.

3. Set the Tweening option to Shape and click OK.

4. Press Return to preview the animation.
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A shape tween is indicated on the Timeline as an arrow on a green background (if you see a
dashed line, it indicates something is wrong with the tween; be sure you specified Shape Tween
rather than Motion Tween in the Frame Properties dialog box by repeating Steps 1-3 above).
Because you actually have three shapes on the same layer, it is possible that Flash confused
which shape should turn into the frown, and you may get very bizarre results:

Shape Hints

If Flash does confuse the starting and ending positions of shapes being tweened, you can use
Shape Hints to map the right eye in Frame 1 to the right eye in Frame 20.
Follow these steps:

1. Select Frame 1 of the Features layer.

2. Choose Modify > Transform > Add Shape Hint. This drops a marker labeled A in the
middle of the Stage.

3. Drag shape hint A and place it at the bottom of the right eye (it will snap to the edge).

4. Choose Modify > Transform > Add Shape Hint again. This will place a marker labeled B
on the stage.

5. Drag shape hint B to one end of the mouth.

6. Select Frame 20. There the corresponding shape hints are still in the center of the stage
(B is on top of A). Drag B to the same end of the mouth and place A at the same location
at the bottom edge of the right eye (the left eye needs no shape hint, as it is the only
other shape on the layer).

7. Press Return to preview the animation.

You can have up to 26 shape hints in a single tween. They will not show in the finished movie, but
if you find them distracting, you can hide them by choosing View > Hide Shape Hints).

Motion Tweening

A less memory-intensive method of tweening is the motion tween. This is where the size,
color, orientation, or position of an object changes over time. You will motion tween the
flying saucer from Lesson 1 to make it appear to fly in from outer space:

1. Create a new Flash movie.

2. Change the color of the Stage to dark blue by choosing Modify > Movie and selecting a
very dark blue for the background color. Press OK.

3. Open the file you saved from Lesson 1 and drag the flying saucer to the new file.

4. Close the old file.

5. Position the saucer in the middle of the Stage.

6. Add a keyframe at Frame 20. (Throughout this course, you'll be instructed to add frames
on frame numbers divisible by five, but that is for your convenience only; these can be
added at any frame in the Timeline.)

7. Select Frame 1 and move the saucer to the top-right corner of the canvas.

8. Select any frame between 1 and 20 and choose Insert > Create Motion Tween.

9. Press Return to preview the movement.
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10. Open the Transform Inspector (Window > Inspectors > Transform), and set the uniform

scale of the Frame 1 saucer to 5 percent. Press Return to preview the results.

Motion Guides

Just as shape hints help Flash during shape tweening, motion guides help during motion
tweening. You can make the flying saucer zig back and forth in its approach by adding a motion

guide layer:

1. Click the blue Add Motion Guide icon next to the New Layer icon.

2. Turn on Onion Skin Outlines by pressing the third icon at the bottom left of the Timeline
(it's a blue square overlapping a white square). Onion-skinning allows you to see where
objects are in other frames.

3. Spread the Onion Skin Markers along the Timeline numbers to encompass all 20 frames

(Figure 2-4). This allows you to see the outlines of all frame contents.

Figure 2-4: Onion Skin Markers

Make sure you're on the new Motion Guide layer and use the Pencil (with Smooth
modifier) to draw a line from the center of the smallest saucer to the center of the largest.
If the outlines of the saucer don't immediately wrap to the shape of the motion guide, you
missed one or both centers by more than a few pixels. Use the Arrow tool to nudge one
or both ends of the line closer to the center of the smallest/largest saucer (magnifying
them with the Zoom tool will help).

Because you don't want the curved motion guide to be visible in the finished movie, hide
the Motion Guide layer by clicking under its eyeball in the Layer palette.

Press Return to preview the results.

Frame-By-Frame Animation

If you are a real glutton for tedium, you can animate the old-fashioned way by changing
the artwork on each successive frame. Frame-by-frame animation is more memory-
intensive because it requires unique artwork on every frame, rather than referencing only
changes in size, shape, or position at certain keyframes. The fewer occurrences of major
artwork in a Flash movie, the smaller the file will be and the faster it will download. The
next lesson shows you how to use symbols to further streamline your movies.
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Using Symbols, Instances, and Sounds

Lesson 3

In the previous lessons, everything you drew was a unique piece of artwork. Every frame
containing the saucer took the same amount of memory to render.

You can dramatically streamline a Flash file by using symbols instead of unique artwork. A
symbol can be used any number of times in the Flash movie while barely increasing the file size.
You'll find that almost everything in a Flash movie should be defined as a symbol.

Kinds of Symbols

Symbols come in three flavors: graphics, buttons, and movie clips.

The Graphic Symbol

Graphics are nothing new -- you've been creating them since Lesson 1. To create the animation
you'll need a flying saucer. You've already drawn one in the file you created in Lesson 1 and used
it again in Lesson 2. Start a new 550 x 400 pixel file with a dark blue background. (Set the
background color by choosing Modify > Movie). To put the saucer in this new file, open either the
Lesson 1 or the Lesson 2 file and drag the flying saucer graphic to the center of your new file.
Because you will use the saucer throughout the rest of the lessons, turn it into a symbol by
selecting it (in the new file) and choosing Insert > Convert to Symbol. Symbols are stored in the
Library (Window > Library).

[3 i Library - saucer fly—in i Now recreate the motion tween and
motion guide of the saucer, (using the
same procedure you did in Lesson 2).
Make the animation cover 15 frames,
and make sure the saucer ends its
motion tween in the center of your
stage. Remember to hide the Motion
Guide layer so it does not display in
the final animation.

7 itemns in library Options «

Symbal praview

MNarne

Sound —T BC:K'? Beam Scan

BEGr

Button symbol — 435 ol button
Graphic symbol - light
Maovie clip - light=
g Reset

Zaucer
i 6 sl
 ~

Maw Mew Symbol Delete
Symbol Folder Properties  Symbol

Figure 3-1: The Library contains all symbols and imported artwork of a Flash file.
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The movie clip Symbol

1. Choose Window > Library if the Library is not already open. Click the New Symbol icon
(the blue "+") at the bottom of the Library palette.

2. Name the new symbol "lights" and choose Movie Clip as its behavior.

3. Notice that now your stage does not have a fixed size, and the top left corner of the
document window appears as if you are working inside a group. This is Symbol Editing
Mode. Draw a green circle on the centerpoint, and duplicate it four times to create a row
of five dull green circles. (Use Modify > Align to distribute them evenly.)

4. Add four more keyframes to the Timeline in Frames 2-5.
5. In Frame 1, change the color of the first circle to a bright neon green.
6. In Frame 2, change the color of the second circle to a bright neon green.

7. Repeat for the remainder of the keyframes, changing the successive circles to a neon
green color. (This is frame-by-frame animation.)

8. Preview the symbol by pressing Return. Make sure that only one circle "lights up" per
frame.

9. Double-click the Saucer symbol in the Library to edit it.

10. Place an instance of the lights movie clip on the body of the saucer. Return to scene 1.
The Lights symbol is now embedded within the Saucer symbol.

11. Choose Control > Test Movie.

A particular occurrence of a symbol in the movie (or nested inside another symbol) is called an
instance. Instances can be transformed like other artwork, without affecting the master symbol in
the Library. They can also have a variety of color effects applied to them (such as transparency),
which you cannot do to unique artwork. If you decide you prefer blue lights on the saucer, you do
not have to edit the five frames of the Lights movie -- just apply a color effect on the lights
instance within the Saucer symbol:

1. Double-click the Saucer symbol in the Library.

2. Select the instance of the Lights symbol on the body of the saucer. Choose Modify >
Instance and click the Color Effects tab.

3. Select Special from the Effect menu.

4. Slide the rightmost Blue slider all the way to the right to increase the color transparency
of blue.

FLA versus .SWF

When you create an animation, you are working in a Flash document (with file extension .fla).
This is not to be confused with the Shockwave/Flash file that will actually be viewed online (.swf).
The difference is analogous to working in a layered Photoshop file (.psd) versus flattening the file
and saving it as a JPEG (.jpg). All the layers, imported artwork, sounds, and unused symbols are
contained within the .fla file, which is larger and cannot be used by anything other than Flash. The
.swf file is much smaller, and contains only the images and sounds actually appearing in the
movie. If you decide to edit the movie, open the .fla file to make the change, and republish the
.swf file (more on this in Lesson 6).
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Buttons

Buttons are needed whenever the user is expected to control something.
Buttons are animations with a maximum of four frames:

el

Normal: This is how the button looks as soon as it appears onstage.
Over: This is how the button looks when the user places the mouse cursor on it
Down: This is how the button looks when the user clicks on it.

Hit: This frame defines the "hot" area of the button; it does not ever display. If, for
instance, you made a button shaped like a spider but wanted the rollover effect to only
occur when the user moused over the abdomen, rather than all the legs, you would
create an abdomen-sized shape in the "hit" frame of the button animation.

& 5 O] v [over [pown] Hit |

Figure 3-2: The timeline of a button symbol.

To create a typical rectangular gray button, open the Library and press the New Symbol icon (+)
at the bottom.

1.

2.

9.

Name the symbol "Restart Button" and choose Button for behavior.
Draw a gray rectangle on the centerpoint

Create the beveled edge by using the Arrow tool to marquee the top side of the rectangle
and filling it with a lighter gray. Do the same for the left side.

Create bevels on the bottom and right sides the same way, using a darker gray.
Add a layer and type the word "RESET" on the new layer.

Add a keyframe to the Over frame of Layer 1. Change the color of the gray rectangle to
yellow (using light yellow for the top-left edges, and dark yellow for the bottom-right
edges).

Add a keyframe to the Down frame of Layer 1 and rotate the entire button (but not the
word) 180° using the Rotate modifier on the Toolbox, the Transform Inspector, or the
Modify > Transform > Rotate command. (This reverses the highlight and shadow edges
to make it look depressed rather than embossed when the user clicks it.)

Do not add anything to the Hit frame -- the shape of the button in the previous frames
determines where the user may strike it.

Return to Scene 1 and place an instance of the Reset Button onstage in the last frame.

10. Choose Control > Enable buttons and try out your new button. (Remember to disable

buttons when you are satisfied that they work; you cannot select a button when it is
enabled.)

To make buttons function, you'll assign ActionScripts to them later.
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Sounds

Sounds add a whole dimension to the user's experience. Sound files can be added to any frame
in the main timeline, or the timeline of a symbol (such as setting the Down frame of a button so
when the user presses, it clicks).

Only .aiff sound files can be imported into Flash on a Macintosh, and only .wav sound files can be
imported into Flash on a PC.

Flash comes with a default sound library that contains many interface element sounds. Open this
by choosing Libraries > Sounds. To add a sound to the button you created in the test button file,
open that file and double-click the Restart Button symbol in the Library. (Notice the Library palette
looks just like the Sounds Library. Don't confuse them; you can add to your file's Library, but not
to the Sounds Library.)

1. In Symbol Editing Mode for the Restart Button symbol, select the Down frame.

2. Drag an instance of the Industrial Door Switch from the Sounds Library to anywhere on
the stage (you can't see sound, so it does not matter where you drop it).

3. Notice the Down frame in the button Timeline has a sound wave form icon in it. Double-
click the frame to open the Frame Properties Dialog box (Fig. 3-5).

[Label [sound [Actions | Tweening |

sound: | Industrial Door Switch w | 22 kHz Stereo 16 Bit
1.1 5 98.8 kB

Effect:
sync:
e loops: [T ]

[&[a] jol#]

Figure 3-3: The Sound tab of the Frame Properties dialog box.
The Industrial Door Switch sound is in stereo, hence the two channels. The upper wave form is
the left channel; the lower is the right channel. Between the two channels is the sound timeline
with In- and Out-control points (they determine how far into the sound file it becomes audible, and
where it stops). The lines above each wave form are called Envelope lines; they set the volume in
each channel (when an Envelope Handle is high, the volume is loud; when one is low, the volume
is reduced).
To the right of the channels are three sound options:

Effect: applies a preset Envelope effect you can modify using the Envelope Handles

Sync: determines if the specified sound should start, stop, stream, or play as soon as
possible in its entirety (Event)
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Loop: the number of times the sound should play consecutively (for continuous sound,
use a very high number)

The default options are best for using a short sound effect such as the Industrial Door Switch.
Click OK.

Return to Scene 1, enable buttons (CONTROL > Enable Buttons) and click your Reset Button.
To add a sound to the flying saucer as it flies in, select Frame 1 of Layer 1 (where the saucer first
appears), and drag an instance of the Beam Scan sound to the stage. Double-click Frame 1 of
Layer 1 to open the Sound tab of the Frame Properties dialog box, and set the effect to fade in.
Click OK, and preview the movie.

Custom Libraries

You can add your own library to the Libraries menu by creating a Flash file with the symbols you
want to appear in the custom library and placing the file in the Libraries folder inside the Flash
Application folder.

Using ActionScripts

What Are Actions?

Actions are commands that are assigned to buttons or to frames. Such commands can be very
simple (such as the Stop action that halts the playback of the movie), or they can be combined
into very complex ActionScripts (multiple actions) that evaluate conditions and perform
accordingly.

ActionScripts are a kind of programming language; if you have ever used JavaScript or Visual
Basic, you will recognize many of the actions in Flash. However, you do not need any
programming experience to create ActionScripts.

Assigning a Frame Action

Use the Saucer.fla file you created. Since movies loop by default, this one plays over and over
when tested. To keep a movie from looping, use an action that stops it when it reaches the last
frame:

1. Add a layer called Actions

2. Insert a blank keyframe in the last frame of the movie on the Actions layer

3. Double-click the blank keyframe you just added to open the Frame Properties dialog box
4. Click the Actions tab

5. Use the "+" dropdown menu to add the Stop action

6. Click OK

7. Press Command-Return (Mac) or Control-Return (Windows) to test the movie
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Assigning a Button Action:
To make the Reset button in your saucer movie restart the movie:
1. Select the Reset button in Frame 1

2. Choose Modify > Instance and click the Actions tab

nertn!ﬂunTEﬂmr E[reclT Rctions ]

+ — .' 15§ w F-
A

On (Refease) | | Epent: []Press
Go to and Stop (1} Release

End On [ Release Dutside

[JRoll duer
] Roll Dut
[] brag Oner
[ brag out

[(1Key Press: D

Figure 4-1: Create ActionScripts in the Actions tab of the Instance Properties dialog box.

3. Use the "+" dropdown menu to add the On MouseEvent action. (This means the action
will begin when the user does something with the mouse.) This is how all Actions
attached to buttons begin.

4. Most actions have specific parameters that must be set. These appear in the right half of
the dialog box. In the case of On MouseEvent, the parameter is which exact mouse
operation triggers the action: pressing, releasing, dragging, etc. Choose the Release
checkbox. (This is the most common way a button operates -- it does nothing until the
user releases the mouse button after pressing it.) Notice the Action in the left half of the
dialog box inserts the proper syntax and punctuation once you select the Release
parameter.

5. From the "+" menu, select the GoTo action.

6. Inthe Parameter side of the dialog box, leave the Frame option set on 1 and check the
Go to and Play box at the bottom.

7. Click OK.

This ActionScript tells the button that when it is released, the movie will immediately go to Frame
1 and begin playing. (The GoTo command -- for reasons only a programmer could fathom --
defaults to Go To and Stop, which is usually not what you want!) When the movie reaches the
last frame, that frame action tells it to stop, rather than loop back to Frame 1, as it would do by
default.
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