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Where to Find Help When You Need It 

 
Help from your Division/College’s Computer Consultant 
Some divisions and colleges have computer consultants assigned to them.  You can contact these 

consultants when you need help.  To determine if you have a consultant assigned to your division or 

college, look to: http://rohan.sdsu.edu/~facstaff 
 

Help from the BATS Web Page  
BATS (Baseline Access, Training and Support) is a California State University initiative to provide all 

students, faculty, and staff with "baseline" access to information resources via networks, training in the 

uses of baseline hardware and software systems, and ongoing professional and technical support for 

utilization of computer resources at San Diego State University.  You can access the BATS Web Page 

by pointing your browser to: http://its.sdsu.edu/~bats/ 
 

Help in the San Diego State University, Faculty Room 
The Faculty Room is staffed Monday through Friday with computing consultants who will try to answer 

your questions.   

Location:    Adams Humanities, 1109 

Phone Number:   x45727 

Semester Hours:   7:30am – 6:00pm Monday -Thursday 

7:30am – 4:30pm Friday 

Semester Intersession:  7:30am – 4:30pm Monday – Friday 

 
Help from the Faculty Computing Help Line 
Phone Number: x41348  E-mail: helpline@mail.sdsu.edu 

Semester Hours:   7:30am – 6:00pm Monday – Thursday 

7:30am – 4:30pm Friday 

Semester Intersession:  7:30am – 4:30pm Monday – Friday 

 

Help from the Staff Computing Help Line 
Phone Number: x40824  E-mail: staffhelp@sdsu.edu 

Semester Hours:   7:30am – 6:00pm Monday – Thursday 

7:30am – 4:30pm Friday 

Semester Intersession:  7:30am – 4:30pm Monday – Friday 

 

http://rohan.sdsu.edu/~facstaff
http://its.sdsu.edu/~bats/
mailto:helpline@mail.sdsu.edu
mailto:helpline@mail.sdsu.edu
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MACROS 
 

 

 

 

 

 

 

 

 

 

Planning The Macro 

 

 

 

 

 

 

Naming The Macro 

 

 

 

 

 

 

 

 

 

 

 

 
 

Recording the Macro 

 

 

 

 

 

 

 

 

 

 

 

 

Microsoft Excel contains a powerful macro language called Visual Basic 

for Applications (VBA).  Macros allow you to automate your work by 

turning a series of actions into a single command. 

 

Macros can be created by writing VBA code or by use of the macro 

recorder.  This document will only discuss the macro recorder. 

 

Recording a macro involves starting the macro recorder, performing the 

steps involved in the macro, then turning off the macro recorder. 

 

 

The simplest, and most effective, way to plan a macro is to write down 

every single step in the process on a piece of paper. 

 

Take note of every time you click a toolbar button, select a command 

from the menus or type information into a cell. 

 

 

Excel will assign a non-descriptive default name to a macro if you do not 

enter your own name.  Use a descriptive name so you can easily identify 

the purpose of the macro. 

 

Names are subject to the following rules: 

 

Å The first character of the macro name must be a letter. 

 

Å Names can contain letters, numbers, and the underscore (_) 

character. 

 

Å Spaces are not allowed 

 

 

Once you are sure you know the exact steps to perform, you are ready to 

record the macro. 

 

1. Open the workbook and activate the worksheet where you want the 

macro to be recorded, and position the active cell where the macro 

should begin. 

 

2. Click on the View tab and then click on Macros in the Macros 

group. 

 

3. Click on Record Macro. 
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Running a Macro 

 

 

 

 

 

 

 

 

Assigning a 

Shortcut Key 

 

 

 

 

 

 

4. Type the name you want to use for the macro.  You can enter a 

shortcut key for your macro now, or you can assign the shortcut key 

later. 

 

5. Select a storage location for the macro. 

 

6. Choose OK to begin recording. 

 

7. At this point you need to decide if you are going to create the macro 

using relative references or absolute references.  The default state of 

the macro uses absolute references.  This is a very literal state.  In 

most cases you will want to use relative references. 

 

8. To use relative references, click on the View tab and then click on 

Macros in the Macros group.  Click on Use Relative References. 

 

9. Perform the actions you have planned for your macro. 

 

10. When finished, Click on the View tab and then click on Macros in 

the Macros group. 

 

11. Click on Stop Recording. 

 

NOTE:  The macro recorder records only the actions that you complete.  

If you cancel a typing entry, backspace a couple of times or 

open a dialog box and cancel, the actions will be ignored. 

 

 

To run a macro: 

 

1. Click on the View tab and then click on Macros in the Macros 

group. 

 

2. Select the name of the Macro you want to run and click on the Run 

button to execute your macro. 

 

 

The fastest way to execute a macro is to assign a shortcut key to run the 

macro. 

 

To set or change a shortcut key: 

 

1. Click on the View tab and then click on Macros in the Macros 

group. 
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Deleting a Macro 

 

 

 

 

 

 

 

 

 

 

 

 

 

Adding A Macro 

to the Quick 

AccessToolbar 

 

 
 

 

 

2. Click on View Macros. 

 

3. Select the name of the desired macro, and then click on the Options 

button.  The Macro Options dialog box appears. 

 

4. Type a letter in the Shortcut Key text box.  If you type an uppercase 

letter, you will need to press the Shift key to run the macro. 

 

5. Click on OK to complete the command. 

 

 

Once you decide that you no longer need a macro, it can be deleted. 

 

To delete a macro: 

 

1. Click on the View tab and then click on Macros in the Macros 

group. 

 

2. Select the name of the macro to be deleted. 

 

3. Click on the Delete button.  A confirmation message will appear. 

 

4. Click on Yes to delete the macro. 

 

 

If you use a macro often enough to make it a valuable tool, but not often 

enough to remember the shortcut keystrokes used to launch the macro, 

you can add the macro to the Quick Access Toolbar. 

 

To add macro buttons: 

 

1. Click on the drop down arrow to the right of the Quick Access 

Toolbar. 

 

2. Click on More Commands. 

 

3. The Excel Options window will open. 

 

4. Click on the drop down arrow in the Choose Commands From 

window. 

 

5. Choose Macros. 

 

6. Select the applicable macro and click on the Add button. 
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Macro Viruses 

 

 
 

 

 

 

 

 

 

 

 

7. Click OK to close the window.  

 

Malicious individuals have been know to imbed viruses in macros.  As a 

result, Microsoft (by default) opens a workbook containing macros in a 

way that the macros cannot run unless you specifically tell Excel to run 

them. 

 

When you open a workbook that contains macros, Excel displays a 

Security Warning telling you that ñMacros have been disabledò. 

 

Click on the Options button where you will see that you have two 

choices of actions when the Security Warning box displays: 

 

Å Help Protect Me From Unknown Content.  The workbook is opened 

but you cannot run any attached macros. 

 

Å Enable This Content.  The workbook is opened and the macros work 

normally.  If a virus is present, you risk damage to your file and your 

computer. 

 

 

IF FUNCTION 
 

 

 

 

 

 

The IF Function is one of the most useful functions available in Excel.  

When you design an IF Function, you ask Excel to perform a test, and 

then you tell Excel what to do if the result of the test is positive or 

negative. 

 

The  syntax you use is as follows: 

 

=IF(logical_test, value_if_true,value_if_false) 

 

While this may look intimidating, it really is quite simple.  Set up a 

worksheet as follows: 
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Assume you enter the following formula in cell D16;   

=IF(A16=1,Faculty,Staff).  The syntax is broken down as follows: 

 

 =IF ï All formulas in Excel start with the equal (=) sign and the IF 

indicates you want Excel to perform the IF Function.  The remaining 

information in inserted within parenthesis. 

 logical_test ï You use the logical test to ask Excel to test something. 

Excel would look at cell A16 and determine if the value of that cell 

equals 1. 

 

 value_if_true – If A16 has a value of 1 then Excel would insert the 

text ñFacultyò in cell D16. 

 

 value_if_false ï If A16 has any value other than 1, Excel would 

insert the text ñStaffò in cell D16. 

 

The value_if_true and value_if_false parts of the function can contain 

text or formulas. 

 

 

NESTED IF 

FUNCTION 

You can insert an IF Function within another IF Function to provide a 

more complex logic in formulas. 

 

For instance, if you wanted to evaluate the years of service for faculty 

and staff members so that you could provide a fee discount based on 

years of service, you could nest an IF Function within an IF Function. 

 

For example, you might want to give a 20% discount for faculty/staff 

with 20 years of service or more, a 10% discount for faculty/staff with 10 

years up to 20 years of service, A 5% discount for faculty/staff with 6 

years up to 10 years of service, and no discount for faculty/staff with less 

than 5 years of service.   

 

If cell B16 contains the years of service for faculty/staff, you could enter 

the following formula in cell F16: 

 

=IF(B16>=20,E16*20%,IF(B16>=10,E16*10%,IF(B16>=5,E16*5%,0))) 
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PROTECTION 
 

 

 

 

 

 

 

 

 

 
 

Setting a Password to 

Open a File 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

There are several levels of protection that you can place on a workbook.  

You can: 

 

 Assign a password that is required before a file can be opened. 

 Assign a password that is required to modify a file. 

 Set up the file so that it is recommended as a ñread-onlyò file. 

 Hide worksheets in a workbook and require a password be used to 

re-display the worksheets. 

 Protect specific cells within a workbook so that changes cannot be 

made to the cells. 

 

 

To assign a password to a workbook: 

 

1. Click on the Microsoft Office Button and then click on Save As. 

 

2. When the Save As window opens, click the Tools button at the 

lower left corner of the window and then click on General Options. 

 

3. Enter the desired password in the Password to open box. 

 

Note:  If you elect to require a password to modify a file, the user 

must know the password to make any changes to the 

workbook.  The user will have the option to open it and view 

it, but cannot save any changes to the file unless the file is 

given a different name. 

 

Note:  If you elect to recommend that users open the workbook as 

read only, keep in mind that this is a recommendation only.  

The users are not prevented from editing and then saving 

changes to the workbook under a different name. 

 

The password can be up to 15 characters long and can include 

spaces.  Passwords are case sensitive. 

 

4. Click on OK and the Confirm Password dialog box will appear. 

 

5. Retype the password (to verify your typing) and click on OK. 

 

6. Click on Save. 

 

7. Write the password down and keep it in a secure place.  If you lose 

the password, you cannot open the file. 
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To Hide Worksheets 

 

 

 

 

 

 

 

 

 

To Protect Cells in a 

Worksheet 
 

 

 

 

 
 

 

To open a password-protected workbook: 

 

1. Click on the Microsoft Office Button, then click on Open.  Navigate 

to the file you want to open. 

 

2. Double-click on the file to be opened. 

 

3. Enter the password in the Password dialog box. 

 

4. Choose OK to open the file. 

 

 

You can hide worksheets and then protect them from being displayed 

without a password. 

 

To hide a worksheet: 

 

1. Select the worksheet to be hidden. 

 

2. Click on the Review Tab and then click on Protect Sheet in the 

Changes group. 

 

When you protect a worksheet, Excel assumes that every cell in the 

worksheet is to be protected.  You need to tell Excel which cells can be 

modified. 

 

1. Select the cells that are permitted to be modified. 

 

2. Click on the Home Tab and then click on Format in the Cells 

group. 

 

3. When the Format Cells dialog box appears, click the Protection 

tab. 

 

4. Click on the Custom Lists tab and then click on the Locked check 

box to remove the check from it, which unlocks the selected cells. 

 

5. Click on OK. 

 

6. Click on the Home Tab and then click on Format in the Cells 

group. 

 

7. When the Format Cells dialog box appears, click Protect Sheet. 
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8. When the Protect Sheet window opens you can choose to use a 

password to unprotect the sheet.  (This is optional.) 

 

9. Click on OK. 

TABLES 

 

 

 

 

 

 

 

 

 

 
 

 

 

Define a Table 

 

 

 

 

 

 
 

Keep Headers in View 

 

 

 

 

Microsoft added intelligent tables to Excel 2007.  If you create a Table 

and click in the Table Excel displays a custom Table ribbon that allows 

you to do a variety of tasks.  You can: 

 

 Automatically add AutoFilter drop-downs to the headings in a 

table 

 Have one-click access to banded rows, columns and other 

autoformats. 

 Toggle a total row on or off. 

 Have onc-click access to removing duplicates. 

 Automatically copy new formulas to all cells in a column. 

 Automaticaly extend a table when new data is added. 

 Extend conditional formatting to the rows in the table. 

 Automatically freeze panes to show the heading row as you scroll 

off the page. 

 Automatically set up range names for an entire table. 

 

A table must be set up so that each column contains the name of a field 

of data.  Each row contains one record of the data. 

 

To define a table, click in any cell of the data and then click on the 

Insert tab and choose Table in the Tables group.  The Create Table 

window will open stating the range of cells that will comprise the table.  

If the range is correct, click OK. 

 

Select one cell in the table and use the scroll bar to scroll down the data 

in the table.  The headings will remain visible at the top of the table. 
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Add a Total Row 

 

 

 

 

 

 

 

 

Expand the Table 

 

To add a total row: 

 

1. Click in any cell in the table.  The Table Tools tab becomes visible. 

 

2. Click on the Table Tools tab then click on the Design tab.  Check 

the Total Row box in the Table Style Options group. 

 

The Total Row can be toggled on and off as you need it. 

 

To expand the table make the cell in the last row and last column of the 

table the active cell.  Press the Tab key and a new row will be added to 

the table. 

 

 

 

 
 

AUTO FILTER 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you are working with a list of items as you would if you had a database 

in Excel, you can use the AutoFilter tool to quickly search through your 

list for particular records. 

 

The AutoFilter tool lets you filter out all records that do not meet your 

criteria.  The list itself is unchanged and you can change the filter at any 

time to display a different set of records. 

 

To apply an AutoFilter to a list: 

 

1. Select a column (or multiple columns or cells in your database), click 

on the Home tab and then click on the Sort & Filter icon in the 

Editing Group. 

 

2. From the drop down menu click on Filter. 

 

3. Excel will display an arrow button for each selected column or group 

of cells at the top of the columns.  These buttons activate pull-down 

menus that allow you to show individual records meeting your 

selected criteria. 

 

4. To display a filtered list of records, click on one of the buttons and 

select your desired criteria.  You can select a single value or multiple 

values. 

 

5. The CUSTOM is accessed by clicking on either the Text Filter or 

Number Filter option in the drop down menu.  It allows you to 

display criteria meeting your customized needs.  State your 

comparison criteria by selecting the desired operator then enter the 
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comparison value in the window on the right. 

 

You can use multiple comparison criteria by selecting the AND or OR 

options and entering the desired criteria in the lower two windows. 

 

 
 

 

ADVANCED 

FILTER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Filter in Place 

 

 

 

 

 

 

When using Excel as a database, you can query information by the use of 

filters.  Filters allow you to extract data based on criteria you specify. 

 

To filter your data you must first establish the criteria area and then input 

your criteria. 

 

1. Insert three new rows at the top of your database. 

 

2. Select the labels for all of the fields. 

 

3. Copy these labels. 

 

4. Paste these labels in Row 1.  Rows 2 and 3 are now ready for you to 

establish your criteria. 

 

5. Enter the criteria you want to use to filter your database. 

 

 Note:  Criteria entered on the same row will be treated as an ñandò 

condition.  Criteria entered on different rows will be treated as an 

ñorò condition. 

 

 

To perform a filtering action that will place the search results in the 

location of the existing database: 

 

1. Select any cell in your database. 

 

2. Click on the Data tab and then click on Advanced in the Sort & 

Filter group.  The Advanced Filter window will appear. 
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Filter to 

Another Location 

3. Excel will guess at the range of data you want to filter.  If the guess 

is correct accept the entry in the List Range box.  If it is not correct, 

click the Collapse Dialog button to the right of the List Range box.  

The dialog box will collapse. 

 

4. Select the cells that contain the data to be filtered (all field labels 

must be included). 

 

5. Click the Collapse Dialog button again to restore the dialog box to 

the screen. 

 

6. Enter the range of cells that contain the criteria including the field 

labels. 

 

7. Ensure that Filter the list, in place option is selected. 

 

8. Click on OK.  The filtered data will display. 

 

To place your filtered data in a new location: 

 

1. Select any cell in your database. 

 

2. Click on the Data tab and then click on Advanced in the Sort & 

Filter group.  The Advanced Filter window will appear. 

 

3. Excel will guess at the range of data you want to filter.  If the guess 

is correct, accept the entry in the List Range box.  If it is not correct, 

click the Collapse Dialog button to the right of the List Range box.  

The dialog box will collapse. 

 

4. Select the cells that contain the data to be filtered (all field labels 

must be included). 

 

5. Click the Collapse Dialog button again to restore the dialog box to 

the screen. 

 

6. Enter the range of cells that contain the criteria including the field 

labels. 

 

7. Ensure that Copy to Another Location option is selected. 

 

8. Enter the cell name where you want to see the upper-left corner of 

the filtered data. 

 

9. Click on OK. 
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RAND FUNCTION This function creates a list of randomly generated numbers between 0 

and 1 to a precision of 15 digits.  You can use this function to sort a list 

of items into random order. 

 

Every time the worksheet is recalculated (by entering text or numbers 

into a cell and pressing <ENTER>, the formulas will recalculate and new 

random numbers will appear in the spreadsheet cells. 

 

To create a list of random numbers select all the cells and type 

=RAND().  Then press Ctrl + ENTER to place this function into all the 

selected cells. 

 

If you do not want the numbers to be recalculated, select the cells with 

the random numbers in them and copy the cells.  Click on the Home tab 

and then click on the bottom half of the Paste button in the Clipboard 

group. 

 

Choose Values.  This will turn the formulas into numbers. 

 

If you need numbers greater than those generated (between 0 and 1), 

simply create a formula to multiply the randomly generated numbers by 

10, 100, 1000, etc.  This will give you numbers greater than 1. 

 


